Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#6108 closed defect (fixed)

No filter list is selected after a migration failure

Reported by: diegocarloslima Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.3.3
Module: Adblock-Browser-for-Android Keywords:
Cc: mario, tpregueiro, jwangenheim Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29626577/

Description (last modified by diegocarloslima)

We have some users that updated ABB to 1.3.x complaining about no ads being blocked. Most of the complaints are related to the fact that no filter list is selected under Settings -> Ad blocking -> Languages. This seems to be due a migration failure (so far we're unable to consistently reproduce it), which causes all the previous filter list settings to be lost. We need to add some recovery mechanism to use the default settings when a migration failure happens.

Hint for testers

Since we can't reproduce this issue (and thus can't yet fix the cause of the problem), we've implemented a mechanism to leverage configuration loss after the upgrade. As soon as ABB starts it checks for migration errors during the upgrade process. If it detects migration issues, ad blocking configuration will be reset. Thus, as soon as migration issues arise, ABB will automatically subscribe to EasyList + EasyList flavor again.

Since this is a really hard to reproduce issue, a special apk was built in order to always cause a failure when loading the filter list from the disk (after the first run, no filter is selected in Settings -> Ad blocking -> Languages) . This way, we can better verify that the 1.3.3 release candidate will recover from this kind of file corruption/migration issue

Change History (7)

comment:1 Changed 11 months ago by mario

  • Milestone set to Adblock-Browser-for-Android-1.3.3

comment:2 Changed 11 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 11 months ago by mario

  • Description modified (diff)

comment:4 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 6108 - No filter list is selected after a migration failure

comment:5 Changed 11 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 11 months ago by diegocarloslima

  • Description modified (diff)

comment:7 Changed 11 months ago by traynard

  • Verified working set

LGTM

Note: See TracTickets for help on using tickets.