Opened 7 months ago

Closed 6 months ago

Last modified 4 months ago

#6113 closed defect (fixed)

[webextension] Error when using block element in Firefox 51

Reported by: Ross Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.0.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: trev, sebastian, kzar, greiner Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29632566/
https://codereview.adblockplus.org/29632569/

Description (last modified by kzar)

Environment

ABP 3.0.1.1939
Firefox 51 / Windows 7

Does not occur on Firefox 52+.

How to reproduce

  1. Have the Firefox Console open.
  2. Navigate to a website (any).
  3. Select [ABP Icon] > [Block element] > Select any element.

Observed behaviour

Often a filter will not be suggested and if the user cancels the dialog, the highlight overlays/styles on the page are not removed. The following error also appears in the console:

TypeError: window.tabs is undefined adblockplus.js:2261:13

Expected behaviour

Block element dialog to be functional, highlights removed if canceled, error not to occur.

Notes

  • This is caused by the let popupPageId = window.tabs[0].id; line in lib/filtercomposer.js, it turns out that window doesn't have a tabs property at all on Firefox 50.
  • This is not a regression since the last release, I can also reproduce with Adblock Plus 3.0.

Change History (9)

comment:1 Changed 7 months ago by kzar

  • Component changed from Unknown to Platform

comment:2 Changed 7 months ago by kzar

  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set

This isn't a regression since the 3.0 release so it's not a release blocker for 3.0.2.

I think we're going to have to consider increasing the minimum supported version of Firefox soon. The WebExtension API is buggy anyway, but in these older versions it's even worse. Options page is broken (#5971), apparently the devenv automatic reload feature doesn't work, block element is broken... probably other stuff too.

comment:3 Changed 6 months ago by kzar

  • Owner set to kzar

comment:4 Changed 6 months ago by kzar

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Summary changed from [webextension] Error when using block element in Firefox 50/51 to [webextension] Error when using block element in Firefox 51

(Note I removed mentions of Firefox 50 since we're dropping support for that.)

comment:5 Changed 6 months ago by abpbot

A commit referencing this issue has landed:
Issue 6113 - Workaround buggy windows.create in Firefox 51

comment:6 Changed 6 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next

comment:7 Changed 6 months ago by abpbot

A commit referencing this issue has landed:
Issue 6113 - Improve reliability of "block element" dialog

comment:8 Changed 6 months ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 4 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Both blocking and cancelling works as expected. There are still some errors in the console while using the functionality but they do not prevent it from working. Errors opened as #6370.

ABP 3.0.2.1968
Firefox 58 / 51 / Beta (59) / Windows 7

Note: See TracTickets for help on using tickets.