Opened 2 years ago

Closed 2 years ago

#6116 closed defect (duplicate)

Entering invalid filters displays error dialog containing "line 1"

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: User-Interface Keywords:
Cc: trev, sebastian, kzar, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 3.0.1.1939
Firefox 57 / Windows 10
Chrome 62 / Windows 10

How to reproduce

  1. Open the options page.
  2. Enter an invalid filter such as example.com$documenttt or example.com$webrtccc.

Observed behaviour

A browser dialog/alert is displayed containing "Line 1".

Expected behaviour

It should display an error message explaining why the filter is invalid. These were printed to console before. I'm not sure if the dialog should be appearing at all?

Change History (1)

comment:1 Changed 2 years ago by kzar

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4829, you were right Ross.

Note: See TracTickets for help on using tickets.