Opened 18 months ago

Closed 9 months ago

#6137 closed defect (worksforme)

Whitelisted website message is being persistent

Reported by: saroyanm Assignee:
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: greiner, arthur Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by saroyanm)

Environment

Firefox: v57
ABP v: 3.0.1.1939beta

How to reproduce

  1. Open options page
  2. In Whitelisted websites tab whitelist example.com
  3. In Advanced tab Add @@||google.com$document filter in CREATE AND EDIT YOUR FILTER LIST section
  4. Reload the options page
  5. Observe

Observed behaviour

  • "example.com" has been whitelisted. message is being show on every reload

Expected behaviour

  • No whitelisting message on page reload

Change History (7)

comment:1 in reply to: ↑ description ; follow-up: Changed 18 months ago by saroyanm

Replying to saroyanm:

  • google.com is added into Whitelisted websites table

@Thomas can you please let me know if you agree to the current statement.

We currently specifically checking ^ to precede the $document (^@@\|\|([^/:]+)\^\$document$)

comment:2 in reply to: ↑ 1 ; follow-up: Changed 18 months ago by greiner

Replying to saroyanm:

Replying to saroyanm:

  • google.com is added into Whitelisted websites table

@Thomas can you please let me know if you agree to the current statement.

We currently specifically checking ^ to precede the $document (^@@\|\|([^/:]+)\^\$document$)

The filter in step (3) should be @@||google.com^$document instead of @@||google.com$document or otherwise it won't be recognized as a filter for the website whitelist. AFAIK the ^ before $document is necessary for indicating the end of the domain.

Last edited 18 months ago by greiner (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 18 months ago by saroyanm

  • Component changed from Unknown to User-Interface
  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

Replying to greiner:

Replying to saroyanm:

Replying to saroyanm:

  • google.com is added into Whitelisted websites table

@Thomas can you please let me know if you agree to the current statement.

We currently specifically checking ^ to precede the $document (^@@\|\|([^/:]+)\^\$document$)

The filter in step (3) should be @@||google.com^$document instead of @@||google.com$document or otherwise it won't be recognized as a filter for the website whitelist. AFAIK the ^ before $document is necessary for indicating the end of the domain.

Okey I wasn't sure if that suppose to not show in the Whitelisted websites, I've updated the ticket accordingly.

@Arthur please let me know if you think this should rather go to the Whitelisted websites tab.

comment:4 Changed 18 months ago by arthur

I think the behaviour should stay like that.

comment:5 follow-up: Changed 9 months ago by greiner

@saroyanm Is this issue still reproducible? I vaguely remember that we fixed something along those lines a while back.

comment:6 in reply to: ↑ 5 Changed 9 months ago by saroyanm

Replying to greiner:

@saroyanm Is this issue still reproducible? I vaguely remember that we fixed something along those lines a while back.

Hmm, that's a good point, I also remember that, but for some reason I can't find where we have fixed that,
AFAIK this was a Race condition bug, also I'm not able to reproduce this issue anymore.

comment:7 Changed 9 months ago by greiner

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for checking. In that case let's close this ticket.

We can just create a new ticket or reopen this one if we encounter it again.

Note: See TracTickets for help on using tickets.