Opened 2 years ago

Closed 2 years ago

#6176 closed change (rejected)

Block upgrade to 3.0 in versions that do not support it (Fx <54)

Reported by: cmjcf Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, mapx, kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

ABP v3 series is marked on AMO with compatibility for Firefox 50+. In versions prior to 54, including the 52 ESR series, key functionality such as the blockable items tab in F12 do not work. Please re-tag the v3 releases with compatibility for 54+ so that ESR users still using 2.9 series releases don't get automatically upgraded to a version with a broken experience.

Change History (4)

comment:1 Changed 2 years ago by mapx

  • Cc trev sebastian added

comment:2 Changed 2 years ago by kzar

  • Cc mapx added
  • Component changed from Unknown to Platform

We're dropping support for Firefox 50 already (#5971), we're working around some problems with the "block element" tool in Firefox 51 (#6113) as well. I'm not sure what we can do about the lack of developer tools API however, except to have the request list shown in a separate page instead of the developer tools (something mapx would like).

comment:3 Changed 2 years ago by fhd

  • Cc trev removed

comment:4 Changed 2 years ago by kzar

  • Cc kzar added
  • Resolution set to rejected
  • Status changed from new to closed

I don't think we'll be dropping Firefox 51, 52 and 53 support for now since the core extension functionality works for those versions. (The fact that the WebExtension version of Adblock Plus has less functionality than the legacy extension is something else.)

Note: See TracTickets for help on using tickets.