Opened 5 years ago

Closed 5 years ago

#618 closed defect (incomplete)

functionality blocked by easylist / social list

Reported by: mapx Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: sebastian, trev Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

chrome 35.0.1916.114, ABP 1.8.3, easylist

How to reproduce

go to
http://www.learnkeeper.com/#dictionary/fr/en/

Try to change the lang by clicking on the dropdown btn "fr-->en"
==> does not work

if I remove easylist (and add for example only easyprivacy) it works
if I use only fanboy's social list ==> does not work

if I use chrome 37 + ABP 1.8.3 ==> it works

forum topic:
https://adblockplus.org/forum/viewtopic.php?f=10&t=23402

in firefox no issues
ABP does not block anything in that page

Attachments (1)

learnkeeper.zip (255.6 KB) - added by trev 5 years ago.
Local copy of the site with the issue reproducible without ABP

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by mapx

  • Component changed from Unknown to Platform

comment:2 Changed 5 years ago by mapx

  • Description modified (diff)

comment:3 Changed 5 years ago by trev

This is being caused by some element hiding rule. Not related to Shadow DOM however, the same issue still occurs even if Shadow DOM isn't used.

comment:4 Changed 5 years ago by trev

It seems that the following selectors are causing it among others:

a[id^="mg_add"]
div[id^="MarketGid"]

Removing all selectors applying to id attribute fixes the issue. This is most definitely a Chrome bug. Unfortunately, this website being a huge block of minified JavaScript doesn't really make it easy to minimize the testcase.

comment:5 Changed 5 years ago by trev

Managed to reproduce this in a local file (wasn't quite trivial, the website apparently doesn't work quite the same if its network requests fail). The following style rule is sufficient to reproduce this: foo[id] {}. In other words, any selector touching id attribute will do, the actual CSS properties associated with it are irrelevant.

comment:6 Changed 5 years ago by mapx

probably (if chrome bug) it was solved in chrome 37 (I didn't try chrome 36 beta)

Changed 5 years ago by trev

Local copy of the site with the issue reproducible without ABP

comment:7 Changed 5 years ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

Yes, this isn't reproducible in Chrome 37. I attached a ZIP archive with the local copy of that webpage - it contains a foo[id] {} style rule which makes this reproducible without Adblock Plus. I think that's as far as we will go: investing effort into reducing a GWT-based website shouldn't be worth it given that the bug is already fixed. If anything, we can try determining when exactly this was fixed, probably not worth the effort either however. And implementing some hack to drop id-based style rules on that website isn't worth it either, disabling Adblock Plus on this website is an easy work-around until Chrome 37 becomes stable (no ads there).

Resolving as invalid because this isn't our bug.

Note: See TracTickets for help on using tickets.