Opened 6 months ago

Closed 5 months ago

Last modified 8 weeks ago

#6191 closed defect (fixed)

"Block Element" button shown for Chrome webstore

Reported by: kzar Assignee: mjethani
Priority: P2 Milestone: Adblock-Plus-3.0.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: sebastian, mjethani Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

Description

Environment

Chrome 62, adblockpluschrome 62e3fd8a8949, Debian Buster

How to reproduce

  1. Open a new tab.
  2. Navigate to https://reddit.com
  3. Click the ABP logo, notice the "Block Element" button is displayed
  4. Navigate to https://chrome.google.com/webstore/category/extensions
  5. Click the ABP logo again.

Observed behaviour

The "Block Element" button is still displayed, clicking it doesn't work properly since our content scripts aren't injected since it's a special protected page.

Expected behaviour

The "Block Element" button isn't displayed for the Chrome Web store.

Notes

  • We noticed this while looking into #6183.

Change History (7)

comment:1 Changed 6 months ago by fhd

  • Cc trev removed

comment:2 Changed 6 months ago by mjethani

  • Owner set to mjethani

comment:3 Changed 5 months ago by abpbot

A commit referencing this issue has landed:
Issue 6191 - Update frame structure for Chrome Web Store pages

comment:4 Changed 5 months ago by mjethani

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Block element does not appear for Chrome web store pages. It does in FF/Opera, but I'm guessing it is not a protected page in non-Chrome.

ABP 3.0.2.1968
Chrome 64 / 49 / Canary (66) / Windows 7
Opera 49 / 36 / Beta (52) / Windows 7
Firefox 58 / 51 / Beta (59) / Windows 7

comment:6 Changed 8 weeks ago by philll

I suspect we may have some regression here: https://adblockplus.org/forum/viewtopic.php?f=10&t=55379

comment:7 Changed 8 weeks ago by sebastian

Seems unrelated to me. Also see #6613.

Note: See TracTickets for help on using tickets.