Opened 2 years ago

Closed 21 months ago

#6206 closed defect (duplicate)

Fix no-js state on acceptableads.com

Reported by: ire Assignee:
Priority: P4 Milestone:
Module: Websites Keywords: goodfirstbug
Cc: juliandoucette, wspee Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Any browser

How to reproduce

  1. Go to acceptableads.com
  2. Remove the js class from the <html> element (or change it to no-js)

Observed behaviour

See that the layout is broken, particularly on mobile.

Expected behaviour

  1. Any style that is only applied to a .js state should also have a workable fallback for .no-js
  2. The <html> element should, by default have a .no-js class that is changed to .js only if JS is enabled

Change History (6)

comment:1 follow-up: Changed 2 years ago by juliandoucette

  • Keywords goodfirstbug added
  • Priority changed from P2 to P3

Reprioritizing because JavaScript doesn't actually add the js/no-js classes (nothing is broken for not-js browsers AFAICT).

comment:2 in reply to: ↑ 1 Changed 2 years ago by ire

Replying to juliandoucette:

nothing is broken for not-js browsers AFAICT

The mobile navigation is not usable without JS

comment:3 Changed 2 years ago by juliandoucette

The mobile navigation is not usable without JS

Ack. Thank you for pointing this out. I don't think this warrants P2 nonetheless.

comment:4 Changed 23 months ago by juliandoucette

  • Priority changed from P3 to P4

comment:5 Changed 23 months ago by juliandoucette

  • Ready set

comment:6 Changed 21 months ago by juliandoucette

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.