Opened 23 months ago

Closed 22 months ago

Last modified 22 months ago

#6215 closed change (rejected)

Create custom email template for ABP Newsletter

Reported by: ire Assignee:
Priority: P2 Milestone:
Module: Websites Keywords:
Cc: jeen, juliandoucette, wspee Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by ire)

Background

In #6210 we are implementing a custom Backclick template for the ABP Newsletter (See Specification).

After users sign up using the form, they receive 2 emails:

  1. An email asking for their confirmation
  2. An email confirming their successful signup to the newsletter

The default Backlcick template isn't appropriate (see screenshot).

What to change

Design and implement a custom newsletter template.

See Specification for Confirmation Email

Attachments (4)

Default Template.png (301.2 KB) - added by ire 23 months ago.
email template - style.jpg (137.2 KB) - added by ire 23 months ago.
email template.jpg (45.3 KB) - added by ire 23 months ago.
extra.html (8.2 KB) - added by juliandoucette 23 months ago.

Download all attachments as: .zip

Change History (19)

Changed 23 months ago by ire

Changed 23 months ago by ire

Changed 23 months ago by ire

comment:1 Changed 23 months ago by juliandoucette

  • Owner set to juliandoucette

comment:2 Changed 23 months ago by juliandoucette

  • Owner juliandoucette deleted

Changed 23 months ago by juliandoucette

comment:3 Changed 23 months ago by juliandoucette

I have attached extra.html which contains the HTML that was discovered inside the Backclick signup form template. This HTML seems to contain two pages responsible for email confirmation.

We no longer use trac for design requests or product specification. Instead, we send design requests to product@… and specify products in gitlab. As a result, I think we should repurpose this ticket to implement the specification of these pages when they are created.

@jeen, @wspee will you please see that this makes it's way into your processes appropriately.

It's hard for me to comment on what's missing because I can't read the pages. But it seems:

  • We are missing English text
  • We are missing content styles if we intend to use this template for more pages than these (I suggest using adblockplus.org styles)
  • I don't think the text at the bottom of the example (Default Template.png) is about unsubscribing...
    • There is no link
    • You can't unsubscribe before you have confirmed

comment:4 Changed 23 months ago by juliandoucette

  • Priority changed from P2 to P5
  • Ready unset

comment:5 Changed 23 months ago by juliandoucette

  • Priority changed from P5 to P2

comment:6 Changed 23 months ago by ire

Resource for developing HTML email - https://github.com/leemunroe/grunt-email-workflow

comment:7 follow-up: Changed 23 months ago by jeen

Created a spec specifically for the email confirmation [on GitLab #118](https://gitlab.com/eyeo/spec/merge_requests/118).

comment:8 Changed 23 months ago by ire

  • Description modified (diff)

comment:9 in reply to: ↑ 7 Changed 23 months ago by ire

Replying to jeen:

Created a spec specifically for the email confirmation [on GitLab #118](https://gitlab.com/eyeo/spec/merge_requests/118).

Thanks Jeen! We also need the email content for the final email sent after the user's subscription has been confirmed.

comment:10 follow-up: Changed 23 months ago by jeen

I don't think it is necessary to have another email confirming the user's subscription? Usually, the message in the redirect page is enough? Otherwise, it is simply cluttering up their inbox with unnecessary mail.

comment:11 in reply to: ↑ 10 Changed 23 months ago by ire

Replying to jeen:

I don't think it is necessary to have another email confirming the user's subscription? Usually, the message in the redirect page is enough? Otherwise, it is simply cluttering up their inbox with unnecessary mail.

Okay. I'll look into how to disable the final email. Thanks!

comment:12 Changed 22 months ago by ire

  • Owner set to ire

comment:13 Changed 22 months ago by ire

  • Owner ire deleted

comment:14 Changed 22 months ago by ire

  • Resolution set to rejected
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.