#6218 closed defect (worksforme)

compile issue with latest libadblockplus c++ type code with ndk (ubuntu os)

Reported by: hehefox Assignee:
Priority: Unknown Milestone:
Module: Libadblockplus Keywords:
Cc: sergz, hfiguiere Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by sergz)

Environment

ndk 12b verison
ubuntu 16.04

How to reproduce

According to prerequisites,setup env var.
Run "make android_arm"

make[2]: Entering directory '/home/hus/work/husong/libadblockplugs_hs/libadblockplus/build'
Android NDK: WARNING:/home/hus/Android/ndk/android-ndk-r12b/sources/cxx-stl/llvm-libc++abi/Android.mk:adblockplus: LOCAL_LDLIBS is always ignored for static libraries    
/home/hus/Android/ndk/android-ndk-r12b/build/core/build-binary.mk:524: warning: overriding recipe for target 'android_arm.release'
/home/hus/Android/ndk/android-ndk-r12b/build/core/build-binary.mk:726: warning: ignoring old recipe for target 'android_arm.release'
Android NDK: WARNING:/home/hus/Android/ndk/android-ndk-r12b/sources/cxx-stl/llvm-libc++abi/Android.mk:googletest: LOCAL_LDLIBS is always ignored for static libraries    
Android NDK: WARNING:/home/hus/Android/ndk/android-ndk-r12b/sources/cxx-stl/llvm-libc++abi/Android.mk:googletest_main: LOCAL_LDLIBS is always ignored for static libraries    
make[2]: *** No rule to make target 'shell/src/Main.cpp', needed by 'local/armeabi-v7a/objs/abpshell/shell/src/Main.o'.  Stop.
make[2]: Leaving directory '/home/hus/work/husong/libadblockplugs_hs/libadblockplus/build'
Makefile:126: recipe for target 'android_multi' failed
make[1]: *** [android_multi] Error 2
make[1]: Leaving directory '/home/hus/work/husong/libadblockplugs_hs/libadblockplus'
Makefile:89: recipe for target 'android_arm' failed
make: *** [android_arm] Error 2

Change History (4)

comment:1 Changed 22 months ago by sergz

  • Cc sergz added
  • Component changed from Unknown to Libadblockplus
  • Description modified (diff)

Could you please add to the issue description what environment variables were set to what values and attach the full output? In addition please run make with V=1.

comment:2 Changed 22 months ago by hfiguiere

  • Cc hfiguiere added

comment:3 Changed 22 months ago by sergz

I think that the problem is that some external gyp is used instead of one from third_party.

Close this issue if there is no additional feedback within 1 month.

comment:4 Changed 21 months ago by sergz

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.