Opened 11 months ago

Closed 11 months ago

Last modified 6 months ago

#6278 closed defect (fixed)

Crash when opening the dropdown menu on Oreo

Reported by: diegocarloslima Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.4.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://issues.adblockplus.org/ticket/6278

Description

Environment

One Plus 5
Android 8.0
Adblock Browser abb_fennec_56_0_merge

How to reproduce

  1. Open the app and click on the overflow dropdown menu (three vertical dots)

Observed behaviour

The app crashes with the following exception:

01-16 09:20:22.500 19762-19762/org.adblockplus.browser E/AndroidRuntime: FATAL EXCEPTION: main
 Process: org.adblockplus.browser, PID: 19762
 java.lang.NullPointerException: Attempt to invoke interface method 'android.view.MenuItem android.view.MenuItem.setEnabled(boolean)' on a null object reference
 at org.adblockplus.browser.BrowserAppUtils.updateBlockAdsMenuItem(BrowserAppUtils.java:39)
 at org.mozilla.gecko.BrowserApp.onCreateOptionsMenu(BrowserApp.java:3426)
 at org.mozilla.gecko.GeckoApp.onCreatePanelMenu(GeckoApp.java:523)
 at org.mozilla.gecko.GeckoApp.getMenuPanel(GeckoApp.java:450)
 at org.mozilla.gecko.toolbar.BrowserToolbar.openOptionsMenu(BrowserToolbar.java:881)
 at org.mozilla.gecko.BrowserApp.openOptionsMenu(BrowserApp.java:3460)
 at org.mozilla.gecko.toolbar.BrowserToolbar$7.onClick(BrowserToolbar.java:338)
 at android.view.View.performClick(View.java:6303)
 at android.view.View$PerformClick.run(View.java:24828)
 at android.os.Handler.handleCallback(Handler.java:789)
 at android.os.Handler.dispatchMessage(Handler.java:98)
 at android.os.Looper.loop(Looper.java:164)
 at android.app.ActivityThread.main(ActivityThread.java:6809)
 at java.lang.reflect.Method.invoke(Native Method)
 at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:240)
 at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:767)

Expected behaviour

The app should open the overflow dropdown menu normally. This is due to the fact that the abb_block_ads menu item is missing on the -v26 menu resources .xml files

Change History (4)

comment:1 Changed 11 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 6278 - Crash when opening the dropdown menu on Oreo

comment:3 Changed 11 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 6 months ago by traynard

  • Verified working set
Note: See TracTickets for help on using tickets.