Opened 21 months ago

Closed 15 months ago

Last modified 13 days ago

#6291 closed defect (fixed)

Fix Windows Store devbuild upload routine

Reported by: oleksandr Assignee: tlucas
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: tlucas, sebastian Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29751598/
https://codereview.adblockplus.org/29825555/

Description

We have automated uploads to the Windows Store of our Edge devbuilds in #4549. For that, we needed to set up credentials, as described in #4909.

Currently the authentication to Windows Store is implemented through the refresh token mechanism. Unfortunately there is a rather short expiration time of refresh tokens from Windows Store (14 days). Because of that we quite often have to re-acquire the refresh token. This is why we need to switch to using certificate credentials instead, which do not expire.

The workflow is described here. There is also a sample Python code for acquiring a token using client certificate here.

Change History (12)

comment:1 Changed 19 months ago by sebastian

  • Cc sebastian added
  • Component changed from Sitescripts to Automation
  • Priority changed from Unknown to P2

comment:2 Changed 19 months ago by tlucas

  • Owner set to tlucas

comment:3 Changed 19 months ago by tlucas

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 18 months ago by abpbot

A commit referencing this issue has landed:
Issue 6291 - Use client certificate for Windows Store uploads

comment:5 Changed 18 months ago by tlucas

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 follow-up: Changed 17 months ago by tlucas

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 in reply to: ↑ 6 Changed 17 months ago by tlucas

Replying to tlucas:
We successfully authenticate with the Windows Store - but our builds currently get rejected, hence are not published.

comment:8 Changed 16 months ago by sebastian

As far as I understand, the problem isn't limited to the automated devbuild upload, but the builds generated with build.py build aren't accepted either when manually uploaded to the Windows Store.

For reference, in the meanwhile we used ManifoldJS to generate release and test builds. We could consider integrating ManifoldJS in buildtools, if it no longer requires Windows (?).

comment:9 Changed 16 months ago by tlucas

  • Review URL(s) modified (diff)

comment:10 Changed 15 months ago by abpbot

A commit referencing this issue has landed:
Issue 6291 - add ManifoldJS packaging for Edge

comment:11 Changed 15 months ago by tlucas

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:12 Changed 8 weeks ago by siva123prasad

spam

Last edited 13 days ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.