Opened 11 months ago

Closed 10 months ago

Last modified 10 months ago

#6298 closed defect (fixed)

White pages displayed in current version of Chrome Canary with Adblock Plus enabled

Reported by: weissmar Assignee: mjethani
Priority: Unknown Milestone: Adblock-Plus-3.0.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: mjethani, kzar, sebastian, mapx Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29679796/

Description

I also reported this to Chromium: https://bugs.chromium.org/p/chromium/issues/detail?id=804407

Environment

UserAgent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3328.1 Safari/537.36
Chrome version: 66.0.3328.1
OS Version: 10.0
ABP: 1.13.4
Filter lists: EasyList, Acceptable Ads

How to reproduce

  1. Open Chrome Canary (66.0.3328.1)
  2. Install AdBlock Plus
  3. On the chrome://extensions page, disable and then re-enable AdBlock Plus
  4. Navigate to any webpage (e.g. wikipedia.org)

Observed behaviour

A white page (without any content) is displayed. This happens whether or not ABP is blocking/hiding anything on the page.

Expected behaviour

The page (with all non-ad content) should be displayed.

Change History (19)

comment:1 Changed 11 months ago by rscott

  • Component changed from Unknown to Adblock-Plus-for-Chromium
  • Platform changed from Unknown / Cross platform to Chrome
  • Summary changed from White pages displayed in current version of Chrome Canary with AdBlock Plue enabled to White pages displayed in current version of Chrome Canary with AdBlock Plus enabled

comment:2 Changed 11 months ago by rscott

Thanks for filing this bug report! =)

When I looked at this in Chrome Canary, it seemed as though disabling all blocking filters (eg Easylist) made the bug go away. When I installed a modified version of Easylist with all the element hiding filters removed, I didn't encounter this bug. So it seems something to do with the processing of element hiding filters is at fault.

It almost seems as though an element hiding filter hit causes much more than just that element to be blocked.

  • Broken in: Chrome Canary Win/64 Version 66.0.3328.0
  • Not yet broken in: Chrome Dev Win/64 Version 65.0.3322.3

Also reported on Twitter. https://twitter.com/PremiumFrye/status/955466844013518848

comment:3 Changed 11 months ago by hfiguiere

  • Cc mjethani added

comment:4 follow-up: Changed 11 months ago by mjethani

  • Summary changed from White pages displayed in current version of Chrome Canary with AdBlock Plus enabled to White pages displayed in current version of Chrome Canary with Adblock Plus enabled

This is a regression in Chromium and is being tracked at https://crbbug.com/804179

comment:5 in reply to: ↑ 4 Changed 11 months ago by mjethani

Replying to mjethani:

This is a regression in Chromium and is being tracked at https://crbbug.com/804179

This is not a regression, the underlying issue exists in Chrome 63 as well. Adblock Plus just happens to have started using the tabs.insertCSS API in recent Canary builds. We may still be able to fix it in Chromium, but I think Adblock Plus should also implement a workaround in the meanwhile.

comment:6 Changed 11 months ago by mjethani

  • Cc kzar sebastian added
  • Owner set to mjethani

comment:7 Changed 11 months ago by mapx

  • Cc mapx added

comment:8 Changed 11 months ago by mapx

I cannot reproduce the issue in Version 66.0.3330.0 (Official Build) canary (64-bit)
Adblock Plus development build 3.0.2.1953

Last edited 11 months ago by mapx (previous) (diff)

comment:9 Changed 11 months ago by mjethani

@mapx I've uploaded a standalone test case, can you reproduce it with that one?

comment:10 Changed 11 months ago by mjethani

I've submitted a patch to fix the issue in Chromium.

comment:11 Changed 11 months ago by mapx

using that example I can reproduce the issue. However, ABP still works fine for me (+ easylist)

comment:12 Changed 11 months ago by asmirnov

Guys, are you sure it's "Adblock-Plus-for-Chromium" ticket or "Chrome" ticket?
If you mean ABP plugin for Chrome you should change ticket module.

comment:13 Changed 11 months ago by kzar

  • Component changed from Adblock-Plus-for-Chromium to Platform

comment:14 Changed 11 months ago by mjethani

@mapx it's still broken for me on Canary 66.0.3331.0

comment:15 Changed 11 months ago by sebastian

For reference, as a quick fix, we will do an emergency release for Chrome and Opera, backporting #5695 on top of Adblock Plus 1.13.4. This will cause user stylesheets not being used on Chrome, for now. However, eventually we also want to leverage user stylesheets on Chrome, and therefore we seem to have to split up the selectors. Therefore I leave this issue open.

comment:17 Changed 10 months ago by mjethani

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from new to closed

comment:18 Changed 10 months ago by mjethani

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next

comment:19 Changed 10 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Pages are no longer blank when using ABP in Chrome Canary.

ABP 3.0.2.1968
Chrome Canary (66) / Windows 7

Note: See TracTickets for help on using tickets.