#6311 closed change (worksforme)

Make a use of templating engine and/or Web Components and/or VirtualDOM in adblockplusui

Reported by: saroyanm Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: greiner Blocked By:
Blocking: #6117 Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by saroyanm)

Background

There are couple of benefits of using templating engine:

  • Using partials(includes or blocks), to separate components into separate files.
  • Reusing repetitive HTML code

We are using Templates already, but we probably need additinal parts, shadow dom, HTML imports, to make a full use of it, the problem is that Shadow Dom and HTML imports are only supported in the Chrome.

Virtual DOM is used in the flattr project, we might want to use it in adblockplusui as well, but we need to find a usecase for that

What to change

This ticket is for continuing the discussion and finding out what of those 3 or combination we need for the adblockplusui.

Change History (5)

comment:1 Changed 17 months ago by saroyanm

  • Blocking 6117 added

comment:2 Changed 17 months ago by saroyanm

  • Description modified (diff)
  • Summary changed from Make a use of templating engine in adblockplusui to Make a use of templating engine and/or Web Components and/or VirtualDOM in adblockplusui

comment:3 Changed 17 months ago by greiner

  • Cc greiner added

comment:4 Changed 12 months ago by greiner

We've started using hyperHTML and splitting up our code into modules using Browserify. Therefore what about closing this ticket?

We can always create new tickets for any problems we have/improvements we want to make to the existing system.

comment:5 Changed 12 months ago by saroyanm

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.