Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#6332 closed defect (fixed)

[ABP dev 3.0.2.1963] TypeError: Cannot read property 'sheet' of undefined

Reported by: Lain_13 Assignee: kzar
Priority: P1 Milestone: Adblock-Plus-3.0.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: mjethani, kzar, mapx, Ross, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29683555/

Description (last modified by kzar)

Environment

Google Chrome 63.0.3239.132
Adblock Plus development build 3.0.2.1963

How to reproduce

  1. Add any list of filters with hiding filters. EasyList is enough.
  2. Refresh any page, even this one.

Observed behaviour

Error in event handler for (unknown): TypeError: Cannot read property 'sheet' of undefined
    at ElemHide.addSelectorsInline (chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/include.preload.js:619:18)
    at browser.runtime.sendMessage.response (chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/include.preload.js:681:14)

Expected behaviour

No errors related to ABP in the console, hiding works as intended.

Notes

Change History (9)

comment:1 Changed 17 months ago by mapx

  • Cc mjethani kzar mapx added

comment:2 Changed 17 months ago by kzar

  • Cc Ross sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Priority changed from Unknown to P1
  • Ready set

comment:3 Changed 17 months ago by kzar

  • Owner set to kzar

comment:4 Changed 17 months ago by kzar

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 17 months ago by abpbot

A commit referencing this issue has landed:
Issue 6332 - Fix typo in recent inline style changes

comment:6 Changed 17 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 follow-up: Changed 17 months ago by Lain_13

Looks fine in 3.0.2.1964

comment:8 in reply to: ↑ 7 Changed 17 months ago by kzar

Replying to Lain_13:

Looks fine in 3.0.2.1964

Great, thanks for confirming.

comment:9 Changed 17 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 3.0.2.1968
Chrome 64 / 49 / Canary (66) / Windows 7
Opera 49 / 36 / Beta (52) / Windows 7
Firefox 58 / 51 / Beta (59) / Windows 7

Note: See TracTickets for help on using tickets.