Opened 21 months ago

Closed 6 weeks ago

#6338 closed change (duplicate)

"Block element" tool gives no feedback about whitelisted elements

Reported by: kzar Assignee:
Priority: Unknown Milestone:
Module: User-Interface Keywords:
Cc: greiner, jeen, aarbor989, rscott Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Background

In #6048 Rick reported that the "Block element" tool wasn't working, he had element hiding whitelisted for a page and so the tool did not suggest any element hiding filters. (It also didn't suggest many blocking filters, but that's the focus of #6048.)

The tool didn't provide any feedback to him about what was happening, so despite this being the expected behaviour it seemed broken.

To see for yourself add the filter @@||cnet.com^$elemhide , then browse here and attempt to use the "Block element" tool.

What to change

I'm not sure, perhaps we could provide visual feedback to users that an element is whitelisted by highlighting it a different colour or explaining to them when they click on it.

See also ui#226.

Change History (7)

comment:1 Changed 21 months ago by kzar

  • Description modified (diff)

comment:2 Changed 21 months ago by greiner

I'm not sure, perhaps we could provide visual feedback to users that an element is whitelisted by highlighting it a different colour or explaining to them when they click on it.

I like the idea of outlining where the conflict is but I'd say that we should also help users deal with the conflict because otherwise this can be quite frustrating if we merely point it out. We're not Apple. :D

For instance, we could allow them to disable conflicting filters / filter lists while informing them about the potential consequences of doing so. Furthermore, we could ask them to report this conflict to filter authors so that they can take a look at it.

comment:3 Changed 21 months ago by kzar

That would be even better. "The element you selected is whitelisted by this filter ..., would you like to disable it?" Problem is I don't know if it's (currently) possible to allow the user to disable one filter from a subscription without disabling the whole subscription.

comment:4 follow-up: Changed 21 months ago by kzar

Thinking out loud - maybe we could link this to the issue reporter? "The element you selected is currently whitelisted by this filter, would you like to report this to us / the authors of the filter list?"

comment:5 in reply to: ↑ 4 Changed 21 months ago by greiner

Replying to kzar:

That would be even better. "The element you selected is whitelisted by this filter ..., would you like to disable it?" Problem is I don't know if it's (currently) possible to allow the user to disable one filter from a subscription without disabling the whole subscription.

Yep, it's possible to disable a filter. This was even part of the UI in the legacy version of Adblock Plus for Firefox. The tricky part will be to allow the user to revert this action again since we haven't yet added the ability to en-/disable individual filters to the options page.

We could probably add a section for listing disabled filters as a temporary solution for that but I'd very much prefer introducing proper filter management to the options page.

Replying to kzar:

Thinking out loud - maybe we could link this to the issue reporter? "The element you selected is currently whitelisted by this filter, would you like to report this to us / the authors of the filter list?"

That's one way we could do it, yeah.

comment:6 Changed 12 months ago by greiner

  • Description modified (diff)

Added link to GitLab issue.

comment:7 Changed 6 weeks ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket in favor of ui#226.

Note: See TracTickets for help on using tickets.