Opened 21 months ago

Closed 21 months ago

Last modified 20 months ago

#6343 closed defect (fixed)

Element hiding filters no longer work after adblockpluschrome changeset ​7247eb4632fa

Reported by: mjethani Assignee: mjethani
Priority: P1 Milestone: Adblock-Plus-3.0.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: kzar, sebastian, mapx, Ross Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29686631/

Description

Environment

Adblock Plus built off the master branch of adblockpluschrome
Any filter list with element hiding filters

How to reproduce

Open any web page where element hiding filters are supposed to work.

Observed behaviour

Element hiding filters no longer work.

Expected behaviour

Element hiding filters should work.

Notes

Changeset 7247eb4632fa caused a regression due to the way our API wrappers are implemented. We expect tabs.insertCSS to throw an error, which it does, but that error is turned into a promise rejection by the wrapper. We do not handle the promise rejection.

Change History (6)

comment:1 Changed 21 months ago by mjethani

  • Review URL(s) modified (diff)

comment:2 Changed 21 months ago by kzar

  • Cc mapx Ross added
  • Priority changed from Unknown to P1
  • Ready set

comment:3 Changed 21 months ago by mjethani

  • Owner set to mjethani

comment:4 Changed 21 months ago by mjethani

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 20 months ago by Ross

Looks fixed in Chrome 64 and Firefox 58 (will verify after checking older browsers too).

comment:6 Changed 20 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Element hiding filters look to be working as expected.

ABP 3.0.2.1968
Chrome 64 / 49 / Canary (66) / Windows 7
Opera 49 / 36 / Beta (52) / Windows 7
Firefox 58 / 51 / Beta (59) / Windows 7
Firefox Mobile 57 / Android 7.0.1

Note: See TracTickets for help on using tickets.