Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#6349 closed defect (duplicate)

Can't find a way to disable first run page in Firefox

Reported by: YvanM Assignee:
Priority: Unknown Milestone:
Module: Websites Keywords:
Cc: greiner, kzar, juliandoucette, sebastian, wspee, josue.mouco, mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Debian Buster, Firefox ESR 52.6.0esr-2, AdBlock Plus 3.0.2

How to reproduce

  1. Install ABP system-wide by placing it in /usr/share/firefox-esr/distribution/extensions/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
  1. Try to disable ABP first run page using a preference file in /etc/firefox-esr/local.js, including:
pref("extensions.adblockplus.suppress_first_run_page", true);
// found on https://adblockplus.org/preferences#preferences_for_administrators

or:

pref("extensions.adblockplus.preconfigured.suppress_first_run_page", true);
// found on https://gist.github.com/abphowto/b31658955f5194d561ea
  1. Delete Firefox user profile to start with a fresh one:
rmdir /home/user/.mozilla/

Observed behaviour

Even if I find the preference correctly set in about:config, ABP first run page is still here.

Expected behaviour

As written in the documentation (https://adblockplus.org/preferences#preferences_for_administrators), ABP first run page should not be shown.

Change History (13)

comment:1 Changed 10 months ago by mapx

  • Cc greiner added

comment:2 Changed 10 months ago by greiner

  • Cc kzar juliandoucette added
  • Component changed from Unknown to Websites

Due to Firefox' recent move to web extensions and our consequent release of version 3.0 we cannot access the preferences from the preference file anymore. Instead we have to use managed extension storage which has been introduced in Firefox 57.

There the only preferences we currently expose are:

  • additional_subscriptions
  • suppress_first_run_page

So unless you can wait or switch to a newer Firefox version, you could install the latest version of the legacy Firefox extension and prevent Firefox from auto-updating the extension. I'd advise against that though but wanted to mention it for completeness' sake.

@Julian We need to update the website to reflect the change to Firefox preferences. I'm not entirely sure what the best way is to approach this (maybe Dave can help) but at least I can say that the following pages are affected:

@Dave Do we already have some documentation we could refer to on how to use managed storage? What impact does this have on existing large scale deployments who use Firefox ESR?

comment:3 Changed 10 months ago by kzar

  • Cc sebastian added

I'm not too knowledgeable about this, Sebastian is probably a better person to ask. Having said that looking at the code it seems to only be used for Chrome, we are specifically checking for the Chromium platform. Perhaps we should remove that check since Firefox apparently supports the API as well now.

As for documentation I found the old issue #1488 and linked there a devbuild announcement if that helps?

comment:4 Changed 10 months ago by juliandoucette

  • Cc wspee added

Sebastian will you please sync with Winsley and see that this documentation update goes into the proper channels?

comment:5 follow-up: Changed 9 months ago by josue.mouco

Dear all,

The pref :

lockPref("extensions.adblockplus.suppress_first_run_page", true);

placed in the cfg file doesn't seems to work anymore on Firefox 58 and Adblock Plus 3.0.2.

Do you have any idea how to implement the setting in new version please?

I don't understand how to implement: "Instead we have to use ​managed extension storage which has been introduced in Firefox 57."

Any help will be useful,

comment:6 Changed 9 months ago by mapx

  • Cc josue.mouco mapx added

comment:7 in reply to: ↑ 5 Changed 9 months ago by greiner

Replying to josue.mouco:

I don't understand how to implement: "Instead we have to use ​managed extension storage which has been introduced in Firefox 57."

Any help will be useful,

You need to create a JSON file (manifest) which contains the preferences that you want to pass on to the extension and you need to place that file in a specific location.

Here are some helpful links with more details:

comment:8 follow-up: Changed 9 months ago by josue.mouco

Thank you for your reply.

I'm sorry, I'm not a good developer. What could be the content of the json file to suppress the first run page please?

comment:9 Changed 9 months ago by mapx

I guess ABP team didn't implement yet the feature for FF 57+.

Last edited 9 months ago by mapx (previous) (diff)

comment:10 in reply to: ↑ 8 Changed 9 months ago by greiner

Replying to josue.mouco:

I'm sorry, I'm not a good developer. What could be the content of the json file to suppress the first run page please?

For example, on my machine I've created a file at ~/.mozilla/managed-storage/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.json with the following contents:

{
  "name": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}",
  "type": "storage",
  "data": {
    "suppress_first_run_page": true
  }
}

comment:11 Changed 9 months ago by sebastian

To sum it up:

  • The configuration from the issue description (also see the related devbuild announcement) should work with Adblock Plus >=2.6.10,<3.0. It was never meant to work (nor possible to support) with WebExtensions, i.e. Adblock Plus 3.0 and above.
  • There is no (officially supported) way to pre-configure Adblock Plus >=3.0,<=3.0.3 (e.g. in order to suppress the first run page) on any version of Firefox.
  • There will be no (officially supported) way to pre-configure Adblock Plus >=3.0 on Firefox <57.
  • I filed #6474 (to be shipped with Adblock Plus 3.1) which adds support for pre-configurable preferences on Firefox >=57, through managed storage.

As for documentation, there are currently following resources:

  • Announcement covering suppress_first_run_page on Chrome on Windows and Linux.
  • 3801#comment:4 shows a working example for additional_subscriptions on Chrome on Linux, and an untested example for Windows.
  • The description of #6474 includes working examples for suppress_first_run_page and additional_subscriptions on Firefox >=57.
  • Howto in form of some GitHub Gists (incomplete and outdated)

I leave it up to the Websites team, to turn these into some proper documentation (on the help center).

Last edited 9 months ago by sebastian (previous) (diff)

comment:12 Changed 9 months ago by wspee

FYI: Ticket to add documentation to help.eyeo.com: https://gitlab.com/eyeo/websites/help.eyeo.com/issues/3

comment:13 Changed 9 months ago by wspee

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.