Opened 5 years ago

Closed 5 years ago

#636 closed change (duplicate)

ABP should remove Chrome's error message in some blocked iframes

Reported by: arthur Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: mapx Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by arthur)

Background

Update the Acceptable Ads whitelist and go to this page. If you scroll down, you will notice a grey placeholder after the first image in the article where it says "Sponsored Links". Below the article you will find another one saying "Requests to the server have been blocked by an extension." when hovering it (see screenshot).

What to change

Adblock Plus should remove those ugly error messages since you don't see them in AdBlock when using the same exception rules.

Additional information

The example site has one Google Adsense ad on the right sidebar whitelisted by Acceptable Ads. So some initial ad scripts from Google are whitelisted but only one ad iframe is whitelisted, the others remain blocked. For some reason this causes such an error message.

Note that this issue is only about the messages in the iframes and not the placeholders. Those can probably only be removed by additional element hiding filters.

Attachments (1)

blocked_request.png (10.0 KB) - added by arthur 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by arthur

comment:1 Changed 5 years ago by arthur

  • Description modified (diff)

comment:2 Changed 5 years ago by mapx

  • Cc mapx added

comment:3 Changed 5 years ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #581.

Note: See TracTickets for help on using tickets.