Opened 22 months ago

Closed 3 months ago

#6374 closed defect (rejected)

[webextension] Adblock Plus devtools panel is blank on some sites in Firefox

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: kzar, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

ABP 3.0.2.1969
Firefox 59 / Windows 7

How to reproduce

  1. Navigate to https://kick.media/
  2. Open the Adblock Plus devtools panel.
  3. Refresh page.
  4. Add the RuAdList+EasyList subscription.
  5. Refresh the page again.
  6. Close the devtools panel.
  7. Reopen the devtools panel and refresh the page.

Observed behaviour

The Adblock Plus devtools panel does not always seem to load correctly. Sometimes at Step 3 or 5, none of the requests are displayed in the panel. Nearly always at Step 7 the devtools panel is completely blank without even the filtering dropdowns displayed (see attached screenshot).

(The page is also blank after Step 5, but not sure if that is just filtering issues from RuAdList - See hub ticket 7906).

Expected behaviour

The Adblock Plus devtools panel to reliably load and display what is occuring with the page.

Attachments (1)

6374-devtools-blank.jpg (133.7 KB) - added by Ross 22 months ago.

Download all attachments as: .zip

Change History (3)

Changed 22 months ago by Ross

comment:1 Changed 22 months ago by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Adblock Plus devtools panel is blank on some sites in Firefox to [webextension] Adblock Plus devtools panel is blank on some sites in Firefox

I can reproduce this, I suspect it's a bug with Firefox's WebExtension API. If that turns out to be the case we should close this issue and open one at bugzilla.mozilla.org instead.

comment:2 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.