Opened 18 months ago

Closed 18 months ago

Last modified 12 days ago

#6388 closed defect (fixed)

Polyfill exception showing in Adblock Plus devtools panel

Reported by: agiammarchi Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.0.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: greiner, saroyanm, kzar Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29697596/

Description (last modified by kzar)

Environment

Chrome 64, Adblock Plus devenv built from adblockpluschrome d966c9ad659c, Debian Buster

How to reproduce

  1. Open a new tab, browse to any page.
  2. Open the developer tools for the tab, switch to the Adblock Plus pane.
  3. Inspect the Adblock Plus devtools pane (Ctrl + Shift + i)

Observed behaviour

Exceptions showing in the console:

polyfill.js:83 Uncaught TypeError: Cannot convert undefined or null to object
    at wrapAsyncAPI (polyfill.js:83)
    at polyfill.js:224
wrapAsyncAPI @ polyfill.js:83
(anonymous) @ polyfill.js:224

Expected behaviour

No exceptions showing in the console.

Change History (8)

comment:1 Changed 18 months ago by kzar

  • Description modified (diff)
  • Owner set to kzar
  • Platform changed from Unknown / Cross platform to Chrome
  • Priority changed from Unknown to P2
  • Ready set
  • Summary changed from devtools.panels.create is not an own property descriptor to Polyfill exception showing in Adblock Plus devtools panel

comment:2 Changed 18 months ago by kzar

  • Description modified (diff)

For context this issue description was previously fairly verbose and had a focus on what might be causing the problem, rather than how to reproduce it. I should have provided more feedback when I updated the issue and was asked via email why I made the changes that I did. I'll respond here so there's a record.

First of all sorry for not providing more feedback, I hope I didn't piss you off. Thank you for filing the issue, I was glad you did since it gave me enough to be aware of and reproduce the problem.

Issue descriptions for bugs should focus on steps for reproduction (including the exact environment), what the problem looks like and what it should look like when the problem is fixed. You can include guesses about the cause of the problem or other information in a sections called "Notes" or similar at the end of the issue, but that shouldn't be the main focus.

  • Take care to include the version (or revision) of Adblock Plus, instead of saying latest.
  • Take care to provide concrete steps for reproduction, it's not only us who needs to reproduce the problem but testers too. For example I mentioned how to inspect our developer tools pane.
  • Focus on what you've observed, not on what you think might be the cause. To be frank I discard much of what people suggest when investigating an issue. If I can observe what they reported then I can work from there, otherwise I'm stuck.
  • Where possible be succinct.

Again thanks for taking the time to file the issue and sorry for not providing more feedback before.

comment:3 Changed 18 months ago by agiammarchi

Thanks for explaining the best way to report bugs in here, and all points are very fair.

FWIW, after so many years writing JS and contributing to ECMAScript standards or filing bugs to browser vendors I have the tendency to tell exactly what is wrong, where and why, via code examples, and I could not notice any "extra note" or "technical details" in the new issue template, so I've put details in there, where no tester would ever care indeed.

I will follow all these points next time and eventually, if that's OK, comment with code a part in case I've already found the issue.

Apologies for the inconvenience.

Best Regards

comment:4 Changed 18 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 18 months ago by abpbot

A commit referencing this issue has landed:
Issue 6388 - Wrap inherited function properties as well

comment:6 Changed 18 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 17 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Looks fixed. Exceptions/error no longer displayed in console for the devtools panel.

Firefox 53 / 58 / Windows 7
Chrome 49 / 65 / Windows 7
Opera 36 / 51 / Windows 7

comment:8 Changed 12 days ago by Mcgregor123

Last edited 12 days ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.