Opened 6 months ago

Closed 6 months ago

Last modified 4 months ago

#6403 closed change (fixed)

Update adblockplusui dependencies and metadata for options page launch

Reported by: saroyanm Assignee: greiner
Priority: P2 Milestone: Adblock-Plus-3.0.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: greiner, agiammarchi, wspee, kzar, sebastian, Ross Blocked By: #6336
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29664623/

Description (last modified by greiner)

Background

We are planing to introduce new options page to Chrome in addition to the Firefox build and also will roll out updates page.
To make it happen we need to update the adblockplusui dependency and update metadata accordingly.

What to change

  • Update adblockplusui dependency to 08bd84805764
  • Move Desktop and Mobile options page related mappings from metadata.gecko to metadata.chrome
  • Update fonts mapping according to the changes introduced in #6209
  • Add update page and resources introduced in #5943

Changes since last adblockplusui dependency update

Ticket Summary Component
#6316 Add translations for text "English" User-Interface
#6303 Introduce basic foundation for automation in adblockplusui User-Interface
#6297 Add translations from the agencies to the Adblock Plus update page User-Interface
#6209 Different font is used in some translations and Filter Lists table status column missalignment User-Interface
#6177 [ABP UI] Options Page - Overlapping of "Settings" translations User-Interface
#6089 SVG checkbox icon rendering issue User-Interface
#6009 Whitelisting (via options) fails in ABP 3.0 User-Interface
#6008 Add trigger to open Updates page Platform
#5943 Implement Updates Page for Adblock Plus extension User-Interface
#5873 Show information about bundled filter list in the Language Dialog User-Interface
#5813 Make new options page compatible with edge User-Interface


Hints for testers

This update includes two major changes. Firstly the new options page is enabled for the Chrome and Edge extensions and secondly the new updates page is included (but only enabled for the Chrome extension). There are also a bunch of smaller changes.

  • Test that the new options page(Desktop) is enabled for the Chrome and Edge extensions. Test that all functionality is working correctly. It should function the same as on Firefox, except the DNT link and the support link.
  • Test the updates page (#5943) works correctly (open the options page and changes "options.html" in the URL to "updates.html". (See related spec merge request.)
  • Test the updates page is launched at the correct times (#6008)
    • Test that the first-run page is shown once after installing the extension, but not the updates page.
    • Chrome-only: Test that the updates page is shown once after updating the extension from an earlier version, but not the first-run page.
  • Test the updates page is not launched on other platforms such as Firefox.
  • Test the desktop options page works the same as before on Firefox, things to test include adding, toggling, updating & removing subscriptions, changing language settings on the General tab, changing preferences e.g. the ones on the Advanced tab, adding and removing custom filters, the acceptable ads tracking warning (#6031) and whitelisting domains.
  • Test the desktop options page works properly for right-to-left languages e.g. Arabic.
  • Test that the issue reporter works the same as before.
  • Test that the mobile options page works the same as before.

Change History (24)

comment:1 Changed 6 months ago by saroyanm

  • Cc greiner agiammarchi wspee kzar sebastian Ross added
  • Component changed from Unknown to Platform
  • Description modified (diff)

This is yet blocked by the translation import and I'll push soon #6209.

@Thomas can you please update description accordingly for the Update Page changes if needed ? Maybe some hints for the testers and what to change section?

comment:2 in reply to: ↑ description Changed 6 months ago by saroyanm

Replying to saroyanm:

Background

We are planing to introduce new options page to Chrome and Edge in addition to the Firefox build and also will roll out updates page.

@Wspee, Are we going to launch the new options page for Edge as well ? Or plan is only Chrome for now ?

Last edited 6 months ago by saroyanm (previous) (diff)

comment:3 follow-up: Changed 6 months ago by wspee

Ultimately this should be rolled out to all platforms but we want to test it on chrome first using a partial roll out, once it has been rolled out to 100% on chrome we can release it everywhere.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 6 months ago by saroyanm

  • Description modified (diff)

Replying to wspee:

Ultimately this should be rolled out to all platforms but we want to test it on chrome first using a partial roll out, once it has been rolled out to 100% on chrome we can release it everywhere.

Acknowledged, updated the description accordingly.

Note: Make sense to ensure that the edge's inherited metadata from chrome.metadata doesn't include options page changes, but only old options page.

comment:5 follow-up: Changed 6 months ago by greiner

FWIW this is a duplicate of #6008. In hindsight we should've created this ticket instead of the other one but since the dependency update is already under review as part of https://codereview.adblockplus.org/29664623/ I'd suggest finishing that instead. It only needs to be updated to reflect the changes in #6209 as well as to include the upcoming translations.

comment:6 Changed 6 months ago by greiner

  • Description modified (diff)

Added link to updates page spec.

comment:7 in reply to: ↑ 5 ; follow-up: Changed 6 months ago by saroyanm

Replying to greiner:

FWIW this is a duplicate of #6008.

Noted

In hindsight we should've created this ticket instead of the other one but since the dependency update is already under review as part of https://codereview.adblockplus.org/29664623/ I'd suggest finishing that instead.

Fine with me, you want me update #6209 ticket description accordingly?

It only needs to be updated to reflect the changes in #6209 as well as to include the upcoming translations.

Also new options page and the note mentioned here I assume ? I can only see Updates Page relevant information there.

Update: Alternatively we can move the Codereview here. I feel like rolling options page to Chrome, but not Edge, might require additional updates.

Last edited 6 months ago by saroyanm (previous) (diff)

comment:8 in reply to: ↑ 7 ; follow-up: Changed 6 months ago by greiner

Replying to saroyanm:

Fine with me, you want me update #6209 ticket description accordingly?

What would you update? I usually add a section "Notes for dependency update" to a ticket to outline what changes it requires for a dependency update. Is that what you mean?

Also new options and the note mentioned here I assume ?

Yes, that as well.

Update: Alternatively we can move the Codereview here. I feel like rolling options page to Chrome, but not Edge, might require additional updates.

Fine with me. I'll close the other ticket then and move the review here.

comment:9 in reply to: ↑ 8 Changed 6 months ago by saroyanm

Replying to greiner:

Replying to saroyanm:

Fine with me, you want me update #6209 ticket description accordingly?

What would you update? I usually add a section "Notes for dependency update" to a ticket to outline what changes it requires for a dependency update. Is that what you mean?

Were planing to update information about the new options page, but since we are moving the review here, my comment is currently irrelevant.

comment:10 Changed 6 months ago by greiner

  • Owner set to greiner

Assigning myself and setting the ticket status to "codereview" to continue the work from #6008 as discussed. Note, however, that we still need to set the ticket to "ready" since the non-updates page related changes haven't been approved yet.

comment:11 Changed 6 months ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:12 in reply to: ↑ 4 ; follow-up: Changed 6 months ago by greiner

Replying to saroyanm:

Note: Make sense to ensure that the edge's inherited metadata from chrome.metadata doesn't include options page changes, but only old options page.

There seems to be a way to override that in the mapping for Edge but given that #5813 is done and that we don't intend to release to Edge yet anyway, I wouldn't think including the new options page would be an issue. What do you think?

Last edited 6 months ago by greiner (previous) (diff)

comment:13 in reply to: ↑ 12 ; follow-up: Changed 6 months ago by saroyanm

Replying to greiner:

Replying to saroyanm:

Note: Make sense to ensure that the edge's inherited metadata from chrome.metadata doesn't include options page changes, but only old options page.

I don't know whether there's a way to override that in the mapping for Edge but given that #5813 is done and that we don't intend to release to Edge yet anyway, I wouldn't think including the new options page would be an issue. What do you think?

According to Winsley, we first need to ship to Chrome, but I do acknowledge that it's not a trivial task as other builds inherit metadata from Chrome and shipping only to Edge will introduce duplication. So the best/easiest way would be to ship to Edge and Chrome, if Winsley will also agree on that I would also be in favor of releasing to all platforms.

comment:14 in reply to: ↑ 13 Changed 6 months ago by saroyanm

Replying to saroyanm:

Replying to greiner:

Replying to saroyanm:

Note: Make sense to ensure that the edge's inherited metadata from chrome.metadata doesn't include options page changes, but only old options page.

I don't know whether there's a way to override that in the mapping for Edge but given that #5813 is done and that we don't intend to release to Edge yet anyway, I wouldn't think including the new options page would be an issue. What do you think?

According to Winsley, we first need to ship to Chrome, but I do acknowledge that it's not a trivial task as other builds inherit metadata from Chrome and shipping only to Edge will introduce duplication. So the best/easiest way would be to ship to Edge and Chrome, if Winsley will also agree on that I would also be in favor of releasing to all platforms.

Note: We don't have to make a release for Edge, but rather include new options page into the devbuilds. @Winsley ?

comment:15 Changed 6 months ago by kzar

  • Description modified (diff)

comment:16 Changed 6 months ago by wspee

@saroyanm
As discussed, it's not a problem if the update page lands in devbuilds for all platforms as long as the actual release for the other platforms (edge, etc) don't happen before the chrome release has been rolled out to 100%.

comment:17 Changed 6 months ago by kzar

  • Description modified (diff)

The testing instructions were not really good enough, I've looked through the diff of all these changes and had a go at improving them. Please could you check for anything I've missed, and also add details how they can test that the updates page is being triggered at the correct times (and what the correct times are)? Then I can mark this as Ready and continue with the review.

comment:18 follow-up: Changed 6 months ago by saroyanm

  • Description modified (diff)

Added test note for testing options page in Edge extension, as well.

comment:19 Changed 6 months ago by abpbot

comment:20 Changed 6 months ago by greiner

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:21 in reply to: ↑ 18 Changed 6 months ago by kzar

Replying to saroyanm:

Added test note for testing options page in Edge extension, as well.

Thanks for that. Could you guys could add some information about how to test the updates page is triggered correctly? Otherwise I'm happy with the issue now (phew)!

comment:22 Changed 6 months ago by greiner

  • Description modified (diff)

Replying to kzar:

Thanks for that. Could you guys could add some information about how to test the updates page is triggered correctly? Otherwise I'm happy with the issue now (phew)!

Done. However, I'm not sure whether we could easily test whether the updates page behaves correctly as soon as we increment its version in the future since this is the first time we release it.

I also added a quick note that we should verify that the mobile options page works because it has also been indirectly affected.

comment:23 Changed 6 months ago by kzar

  • Priority changed from Unknown to P2
  • Ready set

Perfect thanks, this looks good now.

comment:24 Changed 4 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Dependency tickets work as described. Mobile options page, Firefox options page, LTR languages and the updates page also work as expected.

ABP 3.0.2.1998
Firefox 51 / 58 / Windows 10
Chrome 49 / 65 / Windows 7
Opera 36 / 51 / Windows 7

Note: See TracTickets for help on using tickets.