#6413 closed change (duplicate)

Make texts in DevTools panel translatable

Reported by: greiner Assignee:
Priority: Unknown Milestone:
Module: User-Interface Keywords:
Cc: wspee, Shikitita Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

While the DevTools panel is only meant for a more tech-savvy user group, we should still provide translations for it to make it more accessible and to provide a more consistent user experience.

What to change

  • Create locale/en_US/devtools-panel.json
  • Extract all translatable strings from devtools-panel.html
  • Extract all translatable strings from devtools-panel.js

Change History (4)

comment:1 Changed 22 months ago by greiner

@Tamara @Winsley What do you think about this suggestion?

comment:2 Changed 22 months ago by greiner

  • Summary changed from Translate texts in DevTools panel to Make texts in DevTools panel translatable

comment:3 Changed 22 months ago by wspee

Sure the few strings would only add minimal overhead. It maybe a little bit harder to explain the context?

comment:4 Changed 15 months ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as duplicate of #6880.

Note: See TracTickets for help on using tickets.