#6418 closed defect (fixed)

Override `onShowFileChooser` method

Reported by: asmirnov Assignee:
Priority: P2 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29709555/

Description

Environment

We've introduced internal WebChromeClient impl to handle some events required for ad blocking implementation. However we did not override onShowFileChooser (https://developer.android.com/reference/android/webkit/WebChromeClient.html#onShowFileChooser(android.webkit.WebView, android.webkit.ValueCallback<android.net.Uri[]>, android.webkit.WebChromeClient.FileChooserParams) available since API 21). At the moment it prevents file choosing (reported by partner) file default method definition just returns false.

How to reproduce

  1. Run the app
  2. Navigate to any webpage that requires file choosing
  3. Make sure file chooser dialog is not shown.

...

Observed behaviour

File chooser dialog is not shown

Expected behaviour

External client method should be invoked (if external listener is provided). Default methods to be called otherwise.

Change History (3)

comment:1 Changed 21 months ago by asmirnov

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 21 months ago by asmirnov

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.