Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#6420 closed defect (fixed)

Whitelist filter notification shown on page load

Reported by: greiner Assignee: saroyanm
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: saroyanm, Ross, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29712599/

Description

Environment

Ubuntu 17.10
Chrome 64
Adblock Plus 3.0.2.1975

How to reproduce

  1. Open options page
  2. Add custom filter "foo"
  3. Add whitelisted website "example.com"
  4. Reload page

Observed behaviour

The following notification is shown after adding the website to the whitelist as well as after each page reload:

"example.com" has been whitelisted.

Expected behaviour

Notification should only be shown after adding a new website to the whitelist.

Further infomation

This issue occurs because of the global variable isCustomFiltersLoaded being set globally after the first custom filter list has been loaded. In this case, however, there are two custom filter lists.

Loading the first custom filter list (i.e. the one with the filter "foo" in it), sets isCustomFiltersLoaded = true. That means that when the second custom filter list (i.e. the one for whitelisted websites) is loaded, it appears as if a new filter got added which triggers the notification.

Change History (6)

comment:1 Changed 4 months ago by saroyanm

  • Cc Ross added
  • Owner set to saroyanm

comment:2 Changed 4 months ago by saroyanm

  • Cc kzar added

comment:3 Changed 4 months ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Thanks for noticing This Thomas, I think this should also be true for the Firefox.

comment:5 Changed 3 months ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 3 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 3.0.2.1998
Firefox 51 / 58 / Windows 10
Chrome 49 / 65 / Windows 7
Opera 36 / 51 / Windows 7

Note: See TracTickets for help on using tickets.