Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#649 closed defect (fixed)

Some websites are broken on Safari due to dispatching "error" event synchronusly

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.4-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5761318371983360

Description (last modified by sebastian)

Environment

Safari 7
Filter lists: EasyList and EasyPrivacy

How to reproduce

Go to http://www.lynda.com/

Observed behaviour

The website is rendered empty. That is because the website hides its content, while loading Visual Website Optimizer (a script blocked by EasyPrivacy). There even is a fallback to make sure that the website is shown again if this external script fails to load. But that code expects the error event to be dispatched asynchronously. However we dispatch it directly from inside the beforeload event, which is triggered synchronously as soon as a resource is created.

Expected behaviour

The website should be shown also when the Visual Website Optimizer script is blocked by EasyPrivacy.

Change History (5)

comment:1 Changed 6 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 6 years ago by sebastian

  • Description modified (diff)

comment:3 Changed 6 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 5 years ago by sebastian

  • Platform set to Unknown

Also see #1261.

comment:5 Changed 5 years ago by sebastian

  • Platform changed from Unknown to Safari
Note: See TracTickets for help on using tickets.