Opened 18 months ago

Closed 11 months ago

Last modified 6 months ago

#6493 closed defect (fixed)

"Block element" context menu item doesn't work on first usage on Firefox

Reported by: sebastian Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.5-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: kzar, jsonesen, tschuster, mjethani, greiner Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29901596/

Description

Environment

Firefox 58.0.1 (not reproducible on Chrome)
Adblock Plus 3.0.0, 3.0.2 and ae47c9d78ac7 (current master)

How to reproduce

  1. Install/Reload Adblock Plus
  2. Open a new tab and go to https://google.com/
  3. Right-click the Google logo
  4. Select "Block element" from the context menu

Observed behaviour

A window with blank content opens up. I you close the window, reload the page, and try again, the window contains the "Block element" dialog with the suggested filter to add.

Expected behaviour

The "Block element" dialog should be working the first time, right after loading Adblock Plus.

Change History (14)

comment:1 Changed 18 months ago by jsonesen

  • Owner set to jsonesen

comment:2 Changed 17 months ago by jsonesen

I can now reproduce this behavior in chrome 65, do you mind checking this as well when you have a chance?

*never mind, if you refresh the extension and navigate to a tab which is already opened to google.com the block element option does not appear; this is expected behavior

Last edited 17 months ago by jsonesen (previous) (diff)

comment:3 Changed 17 months ago by jsonesen

  • Cc tschuster mjethani added
  • Owner jsonesen deleted

comment:4 Changed 17 months ago by tschuster

This doesn't reproduce every time for me. Maybe 50%? Right clicking in the window seems to redraw the content? I do see some error in the Browser Console, but I haven't verified yet if they are actually related.

comment:5 Changed 17 months ago by tschuster

Did something change? I can't reproduce this anymore.

comment:6 Changed 17 months ago by sebastian

I can still reproduce it 100% reliably, with Adblock Plus built from master (currently at 53853badc92) and Firefox 58.0.1, when I follow the exact steps from the issue description (most notably I can only reproduce it right after Adblock Plus was loaded).

Also right-clicking in the window correctly redraws the content for me.

Last edited 17 months ago by sebastian (previous) (diff)

comment:7 Changed 15 months ago by jsonesen

Seems I am able to reproduce quite reliably know, pretty much every time and right clicking also redraws the window for me. Is there a way to get the window to update without right clicking as a work around?

comment:8 Changed 11 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:9 Changed 11 months ago by kzar

  • Owner set to kzar

Is there a way to get the window to update without right clicking as a work around?

Yea, I noticed that it would also redraw when I resized the window, and that we can do progmatically too.

comment:10 Changed 11 months ago by sebastian

Nice one!

comment:11 Changed 11 months ago by greiner

  • Cc greiner added

comment:12 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 6493 - Ensure Firefox draws the "Block element" popup window

comment:13 Changed 11 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:14 Changed 6 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. The Block element window is displayed as expected right after loading and in general.

ABP 3.4.3.2253
Firefox 65.0.1 / 51 / Windows 10
Firefox Mobile 65.0.1 / Android 7.1.1
Chrome 72.0.3626.109 / 49.0.2623.75 / Windows 10
Opera 58.0.3135.65 / 36.0.2130.80 / Windows 10
Edge 44.17763.1.0 / Windows 10

Note: See TracTickets for help on using tickets.