#6499 closed defect (invalid)

ABP links are broken on latest ABP UI revision

Reported by: saroyanm Assignee: greiner
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: #6476 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Chrome: v65

How to reproduce

  1. Clone adblockpluschrome
  2. Update the ABP UI dependency to 06741ed4c697
  3. generate a dev build and load in the chrome
  4. Navigate the the subscriptions page
  5. Click on any ABP link

Observed behaviour

Option page is opened, but without Install subscription modal dialog

Expected behaviour

Install a subscription modal dialog is shown

Note

This behavior is observable after current change

Change History (3)

comment:1 Changed 19 months ago by saroyanm

  • Blocking 6476 added
  • Component changed from Unknown to User-Interface

comment:2 Changed 19 months ago by greiner

  • Owner set to greiner

comment:3 Changed 19 months ago by greiner

  • Resolution set to invalid
  • Status changed from new to closed

Turns out we're not only listening to the "app.listen" message in the message responder but also in adblockpluschrome/lib/options.js. There it is used to determine when it is safe to send messages to the options page.

Since we changed the way how the message responder accepts "*.listen" messages as part of #6440, this code no longer works and need to be updated accordingly as part of the dependency update. Therefore I'm closing this ticket and I'll update #6476 accordingly.

Note: See TracTickets for help on using tickets.