Opened 20 months ago

Closed 20 months ago

Last modified 19 months ago

#6503 closed defect (fixed)

Fix builds on Windows

Reported by: oleksandr Assignee:
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: tlucas, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29727637/

Description

In #6021 we have refactored the build.py script. Unfortunately it broke all builds on Windows, since it assumes Windows style line endings (\r\n) in docstring (__doc__), when in reality there are only '\n' symbols.

Environment

Windows 10, FCU. Python 2.7.13

How to reproduce

  1. Initiate any build process. For example build.py build -t edge or build.py devenv -t chrome.

Observed behaviour

Build fails with an error.

Expected behaviour

Build should succeed.

Change History (7)

comment:1 Changed 20 months ago by oleksandr

  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 20 months ago by sebastian

  • Priority changed from Unknown to P2

comment:3 Changed 20 months ago by abpbot

A commit referencing this issue has landed:
Issue 6503 - Fix builds on Windows

comment:4 Changed 20 months ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 19 months ago by Ross

I haven't been able to test this as ensure_dependancies.py eventually fails because it attempts to run bash at some point (for linting I think). Should I just be able to build using the normal windows command line or should I be using Cygwin/Subsystem for Windows/Other?

comment:6 Changed 19 months ago by sebastian

As far as I'm concerned, you can skip testing this part. Whether building the extension succeeds is irrelevant for users, and for the upcoming release. Generally, when testing buildtools changes, its mostly relevant that they don't have any (unexpected) effect on the generated builds.

comment:7 Changed 19 months ago by Ross

Just to note: I still could not build on plain Windows. However building inside Linux Subsystem for Windows 10 works fine.

Note: See TracTickets for help on using tickets.