Opened 6 years ago

Closed 6 years ago

#651 closed defect (incomplete)

Erroneously blocks URL, probably because it contains the word "advert"

Reported by: r1chard Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: mapx Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Ubuntu 12.04, Chrome

How to reproduce

  1. Write a web application which has the word "advert" anywhere in your API urls. In my case, it's an application which has "adverts" of things that are for sale.
  2. Try to access that API via AJAX
  3. Fail
  4. Have to re-write bits of the back end so that the URL scheme is different

Observed behaviour

Javascript driven user interface fails to operate correctly

Expected behaviour

javascript driven interface should present user with list of adverts of items for sale.

Change History (1)

comment:1 Changed 6 years ago by mapx

  • Cc mapx added
  • Resolution set to invalid
  • Status changed from new to closed

easylist subscription contains a lot of "advert" filters
https://easylist-downloads.adblockplus.org/easylist.txt

for example:

.advert.$domain=~advert.ly

so, better don't use that word (or similar ==> check easylist subscription), or, if there are already a lot of sites which are using that piece of code, ask for whitelisting / exceptions filters at easylist support forum (providing pages/ links/ details):
http://forums.lanik.us/

closed as invalid because not an ABP issue (filter issue)

Note: See TracTickets for help on using tickets.