#6523 closed defect (fixed)

URL to "latest" devbuild for Adblock Plus for Firefox points to outdated version

Reported by: tlucas Assignee: tlucas
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: sebastian, Ross, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29733599/

Description

Environment

Browser: Firefox

How to reproduce

  1. Go to https://adblockplus.org/en/development-builds
  2. Click on "Adblock Plus for Firefox"
  3. Allow installing software from this site in the popup-dialog

Observed behaviour

Firefox warns the user:

Firefox has prevented this site from installing an unverified add-on.

Expected behaviour

The extension should be successfully installed.

Note: you can force this behavior by following "older builds" next to "Adblock Plus for Firefox" and clicking on the latest file (e.g Adblock Plus for Firefox 3.0.2.1998 ) manually.

Note

This error happens due to 00latest.xpi not being updated by createNightlies --download.

Change History (5)

comment:1 Changed 19 months ago by tlucas

  • Cc sebastian Ross kzar added

comment:2 Changed 19 months ago by tlucas

  • Owner set to tlucas
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 19 months ago by tlucas

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 19 months ago by abpbot

A commit referencing this issue has landed:
Issue 6523 - Update softlink for downloaded builds

comment:5 Changed 19 months ago by tlucas

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.