#6528 closed defect (duplicate)

Response is undefined messages in background console

Reported by: kzar Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: mjethani, sebastian, Ross Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Firefox 59, Debian Buster, Adblock Plus devbuild from 3d0de467d7f1.

How to reproduce

  1. Remove Adblock Plus.
  2. Ensure you have a few websites open in different tabs.
  3. Install Adblock Plus and open the background console for it.

Observed behaviour

This message appears in the background console several times:

response is undefined  include.preload.js:699
Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist.  ExtensionCommon.jsm:425

Expected behaviour

That message does not appear in the background console.

Notes

  • The problem seems to be that there's no response, or that its undefined at least to the "elemhide.getSelectors" message sent by ElemHide.apply in include.preload.js.

Change History (2)

comment:1 Changed 16 months ago by kzar

  • Platform changed from Unknown / Cross platform to Firefox

comment:2 Changed 16 months ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6498.

Note: See TracTickets for help on using tickets.