Opened 7 months ago

Closed 6 months ago

Last modified 5 months ago

#6544 closed defect (fixed)

Requests sent by Chrome or Adblock Plus get (potentially) blocked

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-3.1-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29739603

Description (last modified by sebastian)

How to reproduce

  1. Open the "Adblock Plus" devtools panel on any tab
  2. Go to the Adblock Plus Options.
  3. Force update filter lists.
  4. Type into the address bar.

Observed behaviour

The filter list downloads initiated by Adblock Plus (in step 3), and the requests sent by Chrome to retrieve suggestions (in step 4), show up in the devtools panel and can potentially be blocked.

Expected behaviour

Adblock Plus should not intercept requests it sends itself, or requests sent by the browser.

Notes

  • The same issue was observed before on Firefox and got addressed with #6010.
  • Since Chrome 63, it's possible to identify requests sent by Chrome or your Chrome extension through the new initiator property. Previously it wasn't possible to distinguish these requests from others.
  • As a side effect of this change, we won't process other requests without context information (e.g. requests sent by Shared/Service Workers) on Chromium <63 anymore.

Change History (6)

comment:1 Changed 7 months ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 7 months ago by sebastian

  • Description modified (diff)
  • Summary changed from Adblock Plus for Chrome potentially blocks its own requests to Requests sent by Chrome or Adblock Plus get (potentially) blocked

comment:3 Changed 6 months ago by sebastian

  • Description modified (diff)

comment:5 Changed 6 months ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Requests from the browser or ABP itself no longer appear in the devtools or can be blocked.

ABP 3.0.4.2042
Firefox 59 / 55 / 51 / Windows 10
Chrome 66 / 58 / 49 / Windows 7
Opera 52 / 45 / 36 / Windows 10

Note: See TracTickets for help on using tickets.