Opened 5 years ago

Closed 5 years ago

#655 closed defect (worksforme)

Facebook freezes when opened on firefox

Reported by: Dr_Osama Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: mapx, arthur, manvel@…, trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 7 SP1, Firefox 29.0.1,AdBlocker 2.6.3, Filter list (Easylist)

How to reproduce

  1. open firefox
  2. open facebook.com

Observed behaviour

facebook page freezes for about 2 minutes when just opened then works just fine then freezes for another 2 minutes and so on.
When I disabled AdBlocker, it worked just fine.

Expected behaviour

It should block the ads without slowing the page!

Attachments (1)

Untitled.jpg (218.9 KB) - added by Dr_Osama 5 years ago.
Screenshot of the page while freezing

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by Dr_Osama

Screenshot of the page while freezing

comment:1 Changed 5 years ago by mapx

  • Cc mapx added

1.Are you using some custom filters for FB ?
2.What other addons are installed ? Did you try disabling all other addons and keep only ABP (and re-test) ?
3.Did you clear your cache (+cookies) ?
4.Did you scan your system for adware / malware ?
use: http://www.softpedia.com/get/Antivirus/Malwarebytes-Anti-Malware.shtml
5.Try a new profile:
http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows
install ABP, re-test

comment:3 Changed 5 years ago by John Percival

I too have this problem. As requested above, I created a new profile, installed ABP. Went to FB - no problems. Turned on bookmarks bar - opened new tab, went to FB - freezes.

comment:4 follow-up: Changed 5 years ago by mapx

Are you using the default firefox theme ?

Last edited 5 years ago by mapx (previous) (diff)

comment:5 Changed 5 years ago by mapx

https://adblockplus.org/forum/viewtopic.php?p=100978#p100978

firefox freezing again even using the default theme

comment:6 Changed 5 years ago by mapx

  • Cc arthur added

comment:7 in reply to: ↑ 4 Changed 5 years ago by John Percival

Replying to mapx:

Are you using the default firefox theme ?

Yes.

comment:8 Changed 5 years ago by arthur

Someone reported that if you turn on the Facebook chat, it's working: http://forums.lanik.us/viewtopic.php?p=57830#p57830

Can you verify that? I still cannot reproduce it.

Last edited 5 years ago by arthur (previous) (diff)

comment:9 Changed 5 years ago by mapx

another user (it's the same user TCCB) reported that by hiding the bookmarks bar it's working too
https://adblockplus.org/forum/viewtopic.php?p=101165#p101165

Last edited 5 years ago by mapx (previous) (diff)

comment:10 Changed 5 years ago by mapx

galacticninja also reported:
https://adblockplus.org/forum/viewtopic.php?p=101171#p101171

"Warning: Unresponsive script

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: https://fbstatic-a.akamaihd.net/rsrc.php/v2/yp/r/21bfDHaSBi6.js:68 "

comment:11 Changed 5 years ago by arthur

He actually meant turning the chat on, not off: http://forums.lanik.us/viewtopic.php?p=57830#p57830

comment:12 Changed 5 years ago by saroyanm

  • Cc manvel@… added

comment:13 Changed 5 years ago by philll

  • Platform set to Firefox

comment:14 Changed 5 years ago by trev

  • Cc trev added
  • Resolution set to worksforme
  • Status changed from new to closed

Judging by the forum discussion, this is clearly an issue with the EasyList filters or the scripts running on facebook.com or both - but certainly not an Adblock Plus bug. The suspicion is that EasyList blocked something that made a script on facebook.com go into an endless loop. Resolving as worksforme given that the issue apparently went away by itself, most likely due to a Facebook update.

Note: See TracTickets for help on using tickets.