Opened 17 months ago

Closed 6 months ago

#6561 closed defect (worksforme)

#?#A:-abp-has(> span:-abp-contains(REKLAMA)) causing problems

Reported by: easylist.polish Assignee:
Priority: Unknown Milestone:
Module: Core Keywords:
Cc: hfiguiere, arthur Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by hfiguiere)

Environment

OS: Ubuntu 17.10
Browser: Google Chrome Version 62.0.3202.75 (Official Build) (64-bit)
ABP: 1.13.5, Easylist, Easylist Polish

How to reproduce

  1. Launch Chrome (on FF there're ploblems with wp.pl, but there is another issue about that
  1. You can disable all filter lists and add only these filters:

wp.pl###sgwp_screening_topnews
wp.pl###aSlot3
wp.pl#?#DIV:-abp-contains(REKLAMA) + DIV > A > DIV > IMG
wp.pl#?#DIV:-abp-contains(REKLAMA) + DIV > DIV > IFRAME

  1. Go to wp.pl
  2. Add filter:

wp.pl#?#A:-abp-has(> span:-abp-contains(REKLAMA))

  1. Refresh wp.pl

Observed behaviour

After adding last filter, previous ones stop to work (this ones with new synthax (#?#))

Expected behaviour

It should hide some ads on sub-pages, instead it doesn't work and deactivates other filters

Change History (6)

comment:1 Changed 17 months ago by hfiguiere

  • Component changed from Unknown to Core
  • Description modified (diff)
  • Summary changed from #?#A:-abp-has(> span:-abp-contains(REKLAMA)) cousing problems to #?#A:-abp-has(> span:-abp-contains(REKLAMA)) causing problems

comment:2 Changed 17 months ago by hfiguiere

  • Cc hfiguiere added

comment:3 Changed 17 months ago by hfiguiere

  • Cc arthur added

comment:4 Changed 17 months ago by hfiguiere

Right now I can't reproduce this problem with 3.0.2 (albeit you need the patch to fix issue #6193 to be able to add these filters)

comment:5 Changed 16 months ago by hfiguiere

I believe this is issue #5436.

comment:6 Changed 6 months ago by hfiguiere

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this on the current dev build. But then I don't get any hits on the filters.

And maybe it was really what is being said comment:5

Note: See TracTickets for help on using tickets.