Opened 19 months ago

Closed 19 months ago

Last modified 18 months ago

#6563 closed defect (fixed)

addonVersion in development builds doesn't contain build number anymore

Reported by: sebastian Assignee: tlucas
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: kzar, tlucas Blocked By:
Blocking: #6567 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29747571/

Description (last modified by sebastian)

Environment

Adblock Plus development builds, any version since 352eabcb110d (~1.13.3)
All target platforms (i.e. Chrome, Firefox and Microsoft Edge)

How to reproduce

  1. Inspect the background page and observe the Network panel.
  2. Go to the options page.
  3. Force filter lists updates.

or

  1. Run ./build.py -t {chrome|gecko|edge} build.
  2. Unpack the generated adblockplus*-*.zip file.
  3. Run grep -R 'addonVersion =' from the directory with the unpacked build.

Observed behaviour

The addonVersion in the generated code (and therefore the addonVersion parameter in the filter list download requests) does not contain the build number (e.g. 3.0.2 instead of 3.0.2.2007).

Expected behaviour

For development builds, the addonVersion should always have four parts with the fourths part being the build/revision number.

Notes

This is a regression that can be pinned down to the buildtools dependency update performed in #5077. The related change in buildtools that caused this bug seems to be #5060 which mistakenly starts getting the version number directly from the metadata.

Change History (11)

comment:1 Changed 19 months ago by sebastian

  • Description modified (diff)

comment:2 Changed 19 months ago by sebastian

  • Summary changed from addonVersion in development builds doesn't contain build number anxmore to addonVersion in development builds doesn't contain build number anymore

comment:3 Changed 19 months ago by tlucas

  • Owner set to tlucas

comment:4 Changed 19 months ago by tlucas

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 19 months ago by tlucas

Please note, this will require a dependency update in adblockpluschrome to completely solve the issue.

comment:6 Changed 19 months ago by tlucas

  • Blocking 6567 added

comment:7 Changed 19 months ago by tlucas

For reference, i created #6567 to do the dependency update.

comment:8 Changed 19 months ago by abpbot

A commit referencing this issue has landed:
Issue 6563 - Assure devbuild-number in info module

comment:9 Changed 19 months ago by tlucas

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:10 Changed 19 months ago by sebastian

  • Description modified (diff)

comment:11 Changed 18 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. The addonVersion in requests from the extension now contain the build number again.

ABP 3.0.4.2044
Firefox 59 / 55 / 51 / Windows 10
Chrome 66 / 58 / 49 / Windows 7
Opera 52 / 45 / 36 / Windows 10

Note: See TracTickets for help on using tickets.