Opened 2 years ago

Closed 2 years ago

#6589 closed defect (fixed)

Element hiding is reported to be not working on simple-adblock.com

Reported by: asmirnov Assignee:
Priority: P2 Milestone:
Module: Adblock-Plus-for-Chromium Keywords:
Cc: oleksandr Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://gitlab.com/eyeo/adblockplus/chromium/merge_requests/18

Description (last modified by asmirnov)

Environment

Samsung Galaxy Note 3, Android 5.0, AdblockChromium branch dev-64.0.3249.2_2.

How to reproduce

  1. Go to http://simple-adblock.com/faq/testing-your-adblocker/
  2. Make sure you can see red rectangle with "element hiding not working" message

Observed behaviour

You can see red rectangle with "Not working" message for element hiding.

Expected behaviour

You should see both green rectangles with test "Tested OK"

Hints for testers

It's pretty important to check that element hiding still works as expected.

Attachments (6)

eh_simple_adblocker.com.zip (12.1 KB) - added by asmirnov 2 years ago.
full log
Screenshot_2018-04-16-14-02-22.jpg (632.2 KB) - added by asmirnov 2 years ago.
screenshot
device-2018-05-08-160724.png (279.4 KB) - added by asmirnov 2 years ago.
expected UI (shot during testing)
device-2018-06-21-115105.png (277.0 KB) - added by asmirnov 2 years ago.
tested because of not working in partners beta apk
device-2018-06-21-115132.png (83.5 KB) - added by asmirnov 2 years ago.
tested because of not working in partners beta apk
simple.com_test.txt.zip (9.5 KB) - added by asmirnov 2 years ago.

Download all attachments as: .zip

Change History (11)

Changed 2 years ago by asmirnov

full log

comment:1 Changed 2 years ago by asmirnov

I can see in the log:

04-16 13:59:07.434 7043-7747 W/chromium: [WARNING:adblock_bridge.cc(84)] Adblock: got 19469 selectors for domain simple-adblock.com
04-16 13:59:07.514 7043-7747 W/chromium: [WARNING:adblock_bridge.cc(160)] Adblock: element hiding - generated JS
04-16 13:59:07.534 7043-7747 W/chromium: [WARNING:adblock_bridge.cc(169)] Adblock: element hiding - called JS

So in general element hiding works, need to double check subscriptions, generated JS and if it's executed.

Last edited 2 years ago by asmirnov (previous) (diff)

comment:2 Changed 2 years ago by asmirnov

  • Cc oleksandr added

Changed 2 years ago by asmirnov

screenshot

comment:3 Changed 2 years ago by asmirnov

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Changed 2 years ago by asmirnov

expected UI (shot during testing)

comment:4 Changed 2 years ago by asmirnov

  • Description modified (diff)

comment:5 Changed 2 years ago by asmirnov

  • Resolution set to fixed
  • Status changed from reviewing to closed

Changed 2 years ago by asmirnov

tested because of not working in partners beta apk

Changed 2 years ago by asmirnov

tested because of not working in partners beta apk

Changed 2 years ago by asmirnov

Note: See TracTickets for help on using tickets.