#6594 closed defect (duplicate)

Procedural hiding doesn't work on Firefox when ABP is installed alongside with Stylus extension and at least one style is active

Reported by: Lain_13 Assignee: mjethani
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mjethani, kzar, hfiguiere, mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29755780/

Description

Environment

Windows 10
Firefox 60.0b12
Adblock Plus 3.0.2
Stylus 1.3.17 (works fine with Stylish 3.0.1)

How to reproduce

  1. Visit test.com
  2. Add filter
    test.com#?#.row .row:-abp-has(p:-abp-contains(custom test))
    
  3. Reload test.com
  4. Add style for test.com
    .columns {
        background-color: whitesmoke
    }
    
  5. Reload test.com

Observed behaviour

At step 3 block of text "Enterprise custom test and lesson software..." with a button is hidden. At step 5 it's visible again with white-ish background.

No error messages in the console.

Expected behaviour

At step 5 text remains hidden, same as at step 3.

Change History (7)

comment:1 Changed 20 months ago by mapx

  • Cc mjethani kzar hfiguiere mapx added

comment:2 Changed 20 months ago by mjethani

  • Summary changed from Procedural hiding doesn't work of Fx when ABP installed alongside with Stylus extension and at least 1 style is active to Procedural hiding doesn't work on Firefox when ABP is installed alongside with Stylus extension and at least one style is active

comment:3 Changed 20 months ago by mjethani

Investigated.

What's happening here is that we get a DOMException ("The operation is insecure.") when we try to access Stylus's CSS rules. Apparently this is expected on Firefox. I've submitted a patch.

comment:4 Changed 20 months ago by mjethani

  • Review URL(s) modified (diff)

comment:5 Changed 20 months ago by mjethani

  • Owner set to mjethani

comment:6 Changed 20 months ago by hfiguiere

Feels like issue #6382

comment:7 Changed 20 months ago by mjethani

  • Resolution set to duplicate
  • Status changed from new to closed

Yup, it's a duplicate of #6382.

Note: See TracTickets for help on using tickets.