Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#6604 closed defect (fixed)

Updates page shown on Firefox

Reported by: greiner Assignee: fhd
Priority: P1 Milestone:
Module: Platform Keywords:
Cc: sebastian, wspee, kzar, fhd Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 10
Firefox 59.0.2
Adblock Plus 3.0.3

How to reproduce

  1. Install a version of Adblock Plus lower than 3.x
  2. Update to version 3.x

Observed behaviour

New tab is opened showing updates page.

Expected behaviour

No new tab is opened.

Further information

Upon inspecting the code I noticed the following line in lib/adblockplus.js for the "info" module which explains why the updates page is shown:

exports.platform = "chromium";

Presumably, the purpose of this is to indicate that both Chromium and Gecko use a similar extension API but I'd argue that categorizing Firefox as "chromium" is misleading and that "webext" would be more accurate if our intention is to indicate that.

Furthermore, I noticed the following line in the same section which may or may not be related:

exports.addonName = "adblockpluschrome";

From what I can tell, this value should be "adblockplusfirefox" as defined in metadata.gecko which indicates that the wrong build was uploaded to AMO in which case I'd imagine there'd be further issues (e.g. wrong options page used on Firefox Mobile).

Attachments (1)

Screenshot_20180421-092757.png (85.8 KB) - added by kzar 3 months ago.
Update page popup for Firefox extension on Android

Download all attachments as: .zip

Change History (7)

comment:1 Changed 3 months ago by kzar

  • Cc kzar added

Changed 3 months ago by kzar

Update page popup for Firefox extension on Android

comment:2 Changed 3 months ago by kzar

I originally posted this comment on #6599, but I'll duplicate it here for completeness:

I use Firefox (60.0) on Android (7.0) with the Adblock Plus extension installed on my phone (Moto G4 Plus) and this morning I saw the updates page popup! Needless to say it didn't look great, screenshot attached.

comment:3 Changed 3 months ago by sebastian

  • Cc fhd added
  • Priority changed from Unknown to P1

Yep, as it seems the build for Chrome has been mistakenly uploaded to AMO.

comment:4 Changed 3 months ago by fhd

  • Owner set to fhd

I'll look into it.

comment:5 Changed 3 months ago by fhd

  • Ready set
  • Resolution set to fixed
  • Status changed from new to closed

Yup, that's what happened. I've re-released 3.0.3 as 3.0.4 and uploaded the XPI to AMO.

Some ideas on what we can do to avoid this issue in the future:

  1. We copy the XPI to the working directory (currently it only ends up in the downloads repo, where I missed it).
  2. We add a note to the release checklist that there's a separate build for Firefox (as opposed to Opera).

comment:6 Changed 3 months ago by sebastian

It seems historically, the Firefox builds only end up in the downloads repository (but FWIW the old release check list for the legacy extension was more explicit about this). The reason that the Chrome/Opera builds end up in the local working directory is mostly because they differ from the version added to the downloads repository (i.e. the signature must be stripped, otherwise you cannot upload it to the CWS).

Anyway, I see how it can cause confusion (leading to a mess like this), to have one build in the local directory that is supposed to be uploaded to two of three websites, while the build supposed to be uploaded to AMO is hidden somewhere else. Therefore I just updated the release checklist template, in order to make it explicit which build has to be uploaded where.

Note: See TracTickets for help on using tickets.