Changes between Initial Version and Version 3 of Ticket #660


Ignore:
Timestamp:
06/11/2014 06:26:54 PM (6 years ago)
Author:
trev
Comment:

Thank you for the info. I was suspecting that HTTP cache v2 API wasn't usable immediately but I couldn't find the corresponding bug. So we can only drop the backwards compat code once we stop supporting anything below Gecko 32, good to know. Too bad that it has to happen in such a hacky way.

I guess we'll see your blog posts via Planet Mozilla, as before.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #660

    • Property Cc honzab added
  • Ticket #660 – Description

    initial v3  
    33 
    44=== What to change === 
    5 Switch to version 2 of the API, continue using version 1 as a fallback. Version 2 was introduced in https://bugzilla.mozilla.org/show_bug.cgi?id=913807, starting with Gecko 27 apparently. We will keep supporting older versions for a while still meaning that we need that fallback. 
     5Switch to version 2 of the API, continue using version 1 as a fallback. Version 2 was enabled in https://bugzilla.mozilla.org/show_bug.cgi?id=913806, this one landed in Gecko 32. We will keep supporting older versions for a while still meaning that we need that fallback.