#6612 closed defect (duplicate)

First-run page opened each time extension loads

Reported by: greiner Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, philll, agiammarchi, Ross, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 7
Firefox 56.0.2
Adblock Plus 3.0.2

How to reproduce

  1. Install extension
  2. Restart browser

Observed behaviour

First-run page opens up after each step.

Expected behaviour

First-run page opens up after first step.

Further information

Based on https://adblockplus.org/forum/viewtopic.php?f=1&t=55371

Change History (6)

comment:1 Changed 20 months ago by sebastian

  • Cc Ross added

I cannot reproduce this with Adblock Plus 3.0.2, 3.0.4 or the current development build.

@Ross: Can you try?

comment:2 Changed 20 months ago by Ross

I cannot reproduce this with 3.0.2, 3.0.4 or the current development build either (tried FF 56, 57, 59). Also tried after upgrading from 3.0 in 56. Will keep trying.

comment:3 Changed 20 months ago by agiammarchi

FYI the proposed hotfix would not prevent this from happening. I'd like to know if this is an isolated case or if there are more users with the same issue.

It would also be lovely to understand if everyone else confused the update page with the first run page, 'cause if we drop the former but we keep the first run and/or the issue is about both, the emergency release wouldn't make much sense.

Last edited 20 months ago by agiammarchi (previous) (diff)

comment:4 Changed 20 months ago by greiner

The underlying problem appears to be the same as for #6599 based on the errors posted there.

comment:5 Changed 19 months ago by kzar

  • Cc kzar added

Sounds like this is a duplicate of #6599, mind if I close this Thomas?

comment:6 Changed 19 months ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

Yep, it is a duplicate of #6599 (at least since I updated the issue description).

Note: See TracTickets for help on using tickets.