Opened 20 months ago

Closed 3 months ago

#6613 closed defect (rejected)

Page-specific items hidden in icon popup on certain web pages

Reported by: greiner Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian, philll, agiammarchi Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Unknown

How to reproduce

  1. Go to YouTube (or Soundcloud)
  2. Open icon popup

Observed behaviour

"Block element" menu item not shown.

Expected behaviour

"Block element" menu item shown.

Further information

Issue started on 2018-04-18.

Based on https://adblockplus.org/forum/viewtopic.php?f=10&t=55379

Change History (5)

comment:1 Changed 20 months ago by greiner

I noticed that the "Block element" menu item is not shown when opening the icon popup before the page has finished loading but it's unclear whether or not that issue is related to the one described in this ticket.

comment:2 Changed 20 months ago by sebastian

I cannot reproduce it with Adblock Plus 3.0.3/3.0.4 or the current development build on Chrome 65 or Firefox 58.

FWIW there are some scenarios in which the "Block element" option is expected to be not available (e.g. when the whole document is whitelisted, or on documents where content scripts cannot run).

I asked for more information on the linked forum thread.

comment:3 Changed 14 months ago by greiner

  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket because we aren't able to reproduce this issue and no further information has been provided since then which could've allowed us to.

comment:4 Changed 14 months ago by greiner

  • Component changed from User-Interface to Platform
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Reopening the issue as one possible scenario got raised which could lead to this behavior. Since Adblock Plus doesn't inject its scripts into tabs that have previously been open, certain features such as "Block element" don't work on those until the tab gets reloaded or the browser or operating system is being restarted.

Based on that assumption, I'll assign this ticket to Platform.

comment:5 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from reopened to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.