Opened 3 months ago

Closed 3 months ago

#6666 closed defect (fixed)

Ad Block Plus doesnt work with other (Bulgarian) languages.

Reported by: ivo22bg Assignee:
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: kzar, mjethani, sebastian, greiner Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 8.1 Enterprise, Chrome Version 66.0.3359.170 (Official Build) (64-bit), Adblock Plus 3.0.3, Ears: Bass Boost, EQ Any Audio!, Data Saver, HTTPS Everywhere, Photo Zoom for Facebook.

How to reproduce

Ad Block Plus doesnt work with other (Bulgarian) languages

Observed behaviour

In Bulgarian user interface I get an error „Variable $hours$ used but not defined.“

Expected behaviour

When I try this in English it works like a charm. But in Bulgarian language not possible to install.
This is a serious issue that has been reported before, but nothing has been done.

Change History (5)

comment:1 Changed 3 months ago by mapx

  • Cc kzar mjethani sebastian greiner added

comment:2 Changed 3 months ago by sebastian

  • Component changed from Unknown to User-Interface

comment:3 Changed 3 months ago by greiner

We're currently looking into the issue on CrowdIn. I've also created gitlab#82 to introduce validation for translation files to avoid such issues in the future.

comment:4 Changed 3 months ago by greiner

  • Priority changed from Unknown to P1
  • Ready set

comment:5 Changed 3 months ago by greiner

  • Resolution set to fixed
  • Status changed from new to closed

It turned out that this problem was caused by some translated strings containing placeholders which didn't exist. The issue was fixed on CrowdIn and the corrected strings have now been imported as part of https://hg.adblockplus.org/adblockplusui/rev/f6cbede1b008.

Note: See TracTickets for help on using tickets.