Changes between Version 1 and Version 2 of Ticket #6675


Ignore:
Timestamp:
05/17/2018 01:09:14 PM (15 months ago)
Author:
kzar
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #6675 – Description

    v1 v2  
    2222 
    2323=== Notes === 
    24 - It appears that WebPack sometimes replaces the info module requires with `__webpack_require__(5)` instead of `__webpack_require__(11)` in the lib/adblockplus.js bundle, which in turn includes the dummy buildtools/info.js file instead of the contents as provided by info-loader.js. 
     24- The "info-loader" rule only applies for the path `adblock-next-gen/buildtools/info.js`, but the info module is required with the relative path by the Adblock Plus code and that ends up resolving to `adblock-next-gen/adblockpluschrome/buildtools/info.js`.