Opened 19 months ago

Closed 3 months ago

#6677 closed defect (rejected)

"Block element" highlighting divs can be hidden by element hiding filters

Reported by: cjsmall Assignee:
Priority: P2 Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: greiner, sebastian, mapx, kzar, mjethani Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

Xubuntu 17.10, Firefox 60.0, Adblock Plus 3.0.4

How to reproduce

  1. Add the filter adblockplus.org##div[style*="background"]
  2. Browse to https://adblockplus.org
  3. Click the ABP extension icon and select "Block element"
  4. Move your mouse over the page for a while.
  5. Click on one element to block it.

Observed behaviour

Elements aren't highlighted yellow when they are hovered over during the selection process.

Expected behaviour

Elements should be highlighted yellow during the selection process.

Change History (6)

comment:1 Changed 19 months ago by mapx

  • Cc greiner sebastian mapx kzar added

comment:2 Changed 19 months ago by greiner

I found that the issue is that some element hiding filters are affecting our own elements we use to highlight elements on the page.

In particular, adding these filters resolves the issue for me:

#@#[style*="block !important"]
#@#div[style*="background"]

Ideally, we would change our approach for highlighting elements so that we are no longer affected by our own filters.

comment:3 Changed 19 months ago by greiner

  • Component changed from Unknown to Platform

comment:4 Changed 19 months ago by kzar

  • Cc mjethani added
  • Description modified (diff)
  • Platform changed from Firefox to Unknown / Cross platform
  • Priority changed from Unknown to P2
  • Ready set
  • Summary changed from ABP Not working properly on this site to "Block element" highlighting divs can be hidden by element hiding filters

I can reproduce on Firefox (59) going back to Adblock Plus 3.0, and on Chrome (66) since 2ce8ff28a652.

comment:5 Changed 19 months ago by kzar

  • Description modified (diff)

comment:6 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.