Opened 2 months ago

Closed 2 months ago

Last modified 4 weeks ago

#6679 closed defect (fixed)

Number shown in icon regardless of user setting

Reported by: greiner Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.2-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: sebastian, kzar, tschuster Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29785558/

Description (last modified by kzar)

Environment

Windows 10
Firefox 60
Adblock Plus 3.1

Kubuntu 14.04 (vmware on Windows 7)
Firefox 60
Adblock Plus 3.1

XUbuntu 16.04

Ubuntu 16.04
Chrome 66
Adblock Plus 3.1

See original report at https://adblockplus.org/forum/viewtopic.php?f=1&t=56813

How to reproduce

  1. Enable EasyPrivacy
  2. Uncheck "Show number in icon" checkbox in icon popup.
  3. Go to https://www.youtube.com/user/ScreenRant/videos (press F5, if necessary)

Observed behaviour

Number in icon is shown.

https://pbs.twimg.com/media/DdUpfAUXUAAf5TG.jpg

Expected behaviour

Number in icon is not shown.

Further information

Checking and unchecking the checkbox again, will hide the number temporarily.
Happens mostly on YouTube channels.

What to change

Make sure to check "show_statsinicon" preference beforehand in each place where we update the badge text in lib/stats.js.

Hints for testers

  • Check the blocked stats counter over the ABP icon works as before. Test things like hiding the counter and enabling it again, or loading a page then enabling the counter afterwards.
  • Check that you can no longer reproduce the bug described in this issue.
  • Check that the stats counter

Change History (11)

comment:1 Changed 2 months ago by greiner

I was unable to reproduce this using the following environments:

Ubuntu 16.04
Firefox 60
Adblock Plus 3.1

Windows 10
Firefox 60
Adblock Plus 3.1

Last edited 2 months ago by greiner (previous) (diff)

comment:2 Changed 2 months ago by sebastian

  • Cc kzar tschuster added

I cannot reproduce it either.

For reference, this also has been reported in a comment on the release announcement. According to that user its only happening sometimes.

Last edited 2 months ago by sebastian (previous) (diff)

comment:3 Changed 2 months ago by greiner

  • Description modified (diff)

Corrected environment in ticket description.

comment:4 Changed 2 months ago by greiner

  • Description modified (diff)

Thanks to some additional information I am now able to reproduce the issue on my end. Interestingly, it only appears while EasyPrivacy is enabled.

I've updated the ticket description to reflect that.

comment:5 Changed 2 months ago by greiner

  • Description modified (diff)
  • Platform changed from Firefox to Unknown / Cross platform

I'm also encountering the issue on Chrome.

comment:6 Changed 2 months ago by greiner

  • Component changed from Unknown to Platform
  • Description modified (diff)

I found that we're not checking the preference value when updating the badge text in new code that was introduced in #5241. Adding that check should be sufficient to fix this regression.

comment:7 Changed 2 months ago by kzar

  • Owner set to kzar
  • Priority changed from Unknown to P2
  • Ready set

Argh, on it.

comment:8 Changed 2 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:9 Changed 2 months ago by abpbot

A commit referencing this issue has landed:
Issue 6679 - Don't show block stats in icon if disabled

comment:10 Changed 2 months ago by kzar

  • Description modified (diff)
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:11 Changed 4 weeks ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 3.1.0.2069
Chrome 67 / 64 / 49 / Windows 7
Firefox 60 / 55 / 51 / Windows 7
Opera 52 / 45 / 38 / Windows 7

Note: See TracTickets for help on using tickets.