Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#668 closed defect (duplicate)

adblock for safari ads spam to the email in outlook

Reported by: sartrik Assignee:
Priority: P2 Milestone:
Module: Core Keywords:
Cc: sebastian Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

OS X Maverics 19.9.3
Darwin Komdiv-Kote.local 13.2.0 Darwin Kernel Version 13.2.0: Thu Apr 17 23:03:13 PDT 2014; root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64
Safari V 7.0.4 (9537.76.4)
Adblock Plus: 1.8
Filters: Adblock Warning Removal List
RuAdList+EasyList
EasyList
EasyPrivacy
Disable Malware
Fanboy's Social Blocking List

How to reproduce

  1. Log in outlook web-interface university email system (surrey365.surrey.ac.uk)
  2. Send email using safari with adblock and adblock plus enabled.
  3. Email message returned with error that it contains spam

The same behaviour for another adblock plugin. http://support.getadblock.com/discussions/problems/10822-adblock-for-safari-ads-spam-to-the-email-in-outlook
With adblock enabled: http://support.getadblock.com/discussions/problems/10822/assets/3c9ab3a3b646bbaa10ae76859374f61234bcb6c2/withadblock.txt?anon_token=

With adblock disabled:
http://s3.amazonaws.com/entp-tender-production/assets/59171027543bde31b0ebf0b80d6de46af83d624b/withoutadblock.txt?AWSAccessKeyId=AKIAISVUXXOK32ATONEQ&Expires=1402748819&Signature=O76D6w1lxIPc58DFjwHiGrkzU2s%3D


#AF_kph1, #JobInformer, #PopWin[onmousemove], #SR_PopOver, #SR_PopOverModa=
lBackground, #ad_ph_2, #ad_ph_3, #ad_ph_4, #ad_ph_8, #ads_iframe, #adv, #ad=
vblock, #cyberinfrm_18, #eropromo_icq, #export_test_inboobs, #fp_adv, #fp_b=
anner, #gaminator { display: none !important; }
modul-search, .module-one-search, .novinator, .onona-block, .pr-AVA, .pr-AV=
A2, .sp_search2_table, .sp_search3_table, .sp_search_table { display: none =
!important; } .surbis_banner, .topbaner, .ya-partner, div[id=3D"DIV_NNN_"]=
, a[href
=3D"http://luckiestclick.com/goto."], body > #flydiv, div[class*=
=3D"notifier_baloon_"], div[id$=3D"notifiers_wrap"], div[id=3D"PC_Teaser_B=
lock"], div[id
=3D"Teaser_Block"], div[id=3D"ads_games_"], div[id=3D"cpa_=
rotator_block"], div[id=3D"rtn4p"], div[id=3D"sblock_inform_"], img[width=
=3D"120"][height=3D"600"], img[width=3D"160"][height=3D"600"], img[width=3D=
"468"][height=3D"60"], img[width=3D"728"][height=3D"90"], noindex > .search=
_result[class*=3D"search_result_"], .a-buttons.blue-but.a-check { display: =
none !important; } .a-buttons.green-but.a-clock, div[style=3D"width: 252px;=

height: 450px; position: fixed; right: 0px; top: 0px; overflow: hidden; z-=

index: 10000;"], #pgeldiz, .rbcobmen, #banner.b-bannercontent, .b-spec-ad


...

Observed behaviour

The problem is that when I am sending messages via the mail outlook web interface, and your plugin (adblock or adblock plus) is enabled in safari, the strange links appears in the body of the message and the spam filter is blocking it.
The first attachment is the dump of the email (with adblock enabled, safari) that I have sent from my email to same address because I can not send to any external one because o the spam filter is not allow to go it out. Look that the actual email text: "empty message" is at the bottom, so before there is an html comment opens.
The second attachment is outgoing email with adblock removed. See that it is clean.
I have not checked if the same happens when using gmail, but when I am sending email from Roundcube mail web interface, outgoing messages is clean.

This happens only on Safari, but firefox adblock or adblock plus does not behave this way.

Expected behaviour

Attachments (2)

withadblock.txt (226.6 KB) - added by sartrik 5 years ago.
with adblock enabled email dump
withoutadblock.txt (1.8 KB) - added by sartrik 5 years ago.
withoutadblock normal message

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by sartrik

with adblock enabled email dump

Changed 5 years ago by sartrik

withoutadblock normal message

comment:1 Changed 5 years ago by mapx

  • Cc sebastian added
  • Priority changed from Unknown to P2

comment:2 Changed 5 years ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

This issue has been reported before, see #369. However I couldn't reproduce it with Adblock Plus. Please note that AdBlock is a different extension, developed by somebody else.

Last edited 5 years ago by sebastian (previous) (diff)
Note: See TracTickets for help on using tickets.