Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#6686 closed defect (invalid)

Element cannot be added to storage.js

Reported by: cjsmall Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mapx, mjethani, kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

Xubuntu 17.10
Firefox 60.0.1
ABP 3.0.4

How to reproduce

Attempts to remove the element:

wired.com##.advertisement__leaderboard

From the wired.com site fails.

Specifically, on the page:

https://www.wired.com/story/congress-latest-move-to-extend-copyright-protection-is-misguided/

This element at the top of the page can be selected and shows up on the filter pop-up. However, selecting Add does NOT add it to the filter list.
I was able to add other elements from this page after this point, but not this one despite repeated attempts.

From the Options page I edited the filter list and pasted it in.
However, it disappears when I do a Save!

A possible related or unrelated issue is that my storage.js file is now 7984288 bytes.
In the old version of ABP, my filter list would grow for a while and then I would notice that it was magically truncated to something around this size, discarding many of my site filters in the process.

I assumed this was fixed in the current version of the program but I'm wondering if I am again bumping up against some hard limit on an internal buffer around 8MB.

I would appreciate someone looking into this to see if there is indeed a problem with the size of custom filters.

Observed behaviour

Cannot add element to filter list.

Change History (8)

comment:1 Changed 16 months ago by mapx

  • Description modified (diff)

comment:2 Changed 16 months ago by mapx

try these filters

wired.com##[class^=adv]
wired.com##.failsafe-desktop

comment:3 Changed 16 months ago by mapx

  • Cc mapx mjethani kzar added

comment:4 Changed 16 months ago by cjsmall

I was able to manually add the two elements you suggested to the filter list and they worked. Thanks.

I'm still unclear why the one identified by ABP can not be added automatically or manually. I see other filters where the element name starts with a period, so that's not it. Do you know the reason? Is this a bug in ABP?

comment:5 Changed 16 months ago by mapx

Well, on my side no issue with adding that filter (but I don't know why it does not work).
Let's see if the devs could clear this issue.

Last edited 16 months ago by mapx (previous) (diff)

comment:6 Changed 16 months ago by mapx

the mistery is not a ...mistery (courtesy of R.Hill - from ublock origin):

easylist contains this exception filter
wired.com#@#.advertisement__leaderboard which unfortunately is not reported in the logger (ABP dev panel)

Last edited 16 months ago by mapx (previous) (diff)

comment:7 Changed 16 months ago by mapx

  • Resolution set to invalid
  • Status changed from new to closed

comment:8 Changed 16 months ago by cjsmall

mapx, thanks for the info. I've seen this happen a few times in the past. That will help explain similar things in the future.

Note: See TracTickets for help on using tickets.