Opened 14 months ago

#6694 new change

Determine the supported versions of V8.

Reported by: sergz Assignee:
Priority: P2 Milestone:
Module: Libadblockplus Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

In #6596 we are switching to another model of consumption of V8. There will be no strict connection to a particular version of V8. Despite the issue sounds like update to V8 6.7.... the update basically affects the building files, not the code. Now it means that one can compile and use libadblocklus with a whole range of versions of V8, e.g. V8 6.5, V8 6.7 and supposedly any revision close to these versions. It gets essential with the growth of the variety of clients where each client has internal constraint on the V8 version.

What to do

IMO we should have a range of supported versions but we should not keep track of them in the README.md for example. Instead we should configure the CI to run libadblockplus with the set of versions of V8, when an old version stops working one should drop that version from the CI config, if it does not harm a partnership, of course. In the README.md file however, we should put a link to the recent build of the main branch (e.g. master) where one can find the list of supported versions of V8.

Change History (0)

Note: See TracTickets for help on using tickets.