Opened 18 months ago

Closed 18 months ago

Last modified 17 months ago

#6713 closed defect (fixed)

$generichide filter option is broken

Reported by: arthur Assignee: kzar
Priority: P1 Milestone: Adblock-Plus-3.2-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: kzar, sebastian, Ross Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://github.com/adblockplus/adblockpluschrome/pull/6

Description (last modified by amrmak)

Environment

Chrome 67.0.3396.62 (Official Build) (64-bit)
ABP 3.1.0.2059

How to reproduce

  1. Add ###main and @@||adblockplus.org^$generichide as custom filters to ABP
  2. Go to https://adblockplus.org/

Observed behaviour

The section with the ID "main" is hidden.

Expected behaviour

It should not be hidden since the $generichide should disable the generic element hiding filter ###main.

Notes

  • This is a regression caused by 939bf6cdd435. The adblockpluscore dependency update missed the integration notes for #6669, the ElemHide.getSelectorsForDomain call wasn't modified.

Change History (7)

comment:1 Changed 18 months ago by kzar

  • Cc Ross added
  • Description modified (diff)
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Priority changed from Unknown to P1
  • Ready set

Yep, I can reproduce and it's a problem since the last release. Investigating.

comment:2 Changed 18 months ago by kzar

  • Description modified (diff)
  • Owner set to kzar

comment:3 Changed 18 months ago by abpbot

A commit referencing this issue has landed:
Issue 6713 - Pass the correct arguments to getSelectorsForDomain

comment:4 Changed 18 months ago by kzar

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from new to closed

comment:5 Changed 18 months ago by kzar

  • Description modified (diff)

comment:6 Changed 17 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 3.1.0.2065
Firefox 51 / 60 / Windows 7
Chrome 49 / 66 / Windows 7
Opera 36 / 52 / Windows 7

comment:7 Changed 17 months ago by amrmak

  • Description modified (diff)
Note: See TracTickets for help on using tickets.